License issue: hfss_solve does not exist in the licensing pool

yugiohmumiyugiohmumi Member Posts: 3

When we check our installed license we can see the following hfss component:

Users of hfsshpc: (Total of 1024 licenses issued; Total of 0 licenses in use)

Users of elec_solve_hfss: (Total of 275 licenses issued; Total of 0 licenses in use)


However, we got the following errors when running Ansys.

“Failed to enable feature using current license settings. Not that Pro, Premium, Enterprise licenses are available on your server. To use these licenses check the corresponding UI option. For more information, search for “PPE” in the help documentation. Failover feature ;HFSS solver’ specified in license preferences is not available. Request name hfss_solve does not exist in the licensing pool. No such feature exists. Feature: hfss_solve License path: 1055@licenseserver_info_here: FlexNet Licensing error: -5,147"


Our target system and license server are all running Linux.

Thanks a lot,

Answers

  • Geo KarnosGeo Karnos Posts: 161Ansys Employee
    edited April 19

    In Electronics Desktop, go to Tools->Options 

    Check the box for: "Use Electronics Pro, Premium, Enterprise product licensing"

    This should fix your issue.

    Best Regards,

    Geo

  • yugiohmumiyugiohmumi Posts: 8Member

    Hi Geo Karnos,

    Thank you for the response.

    Your solution comes from the Windows version with the GUI. But what we use are part of a CLI-only cluster running on CentOS7.

    Do you know if there is any Linux "equivalent" configuration for this?

    Best wishes,

  • Geo KarnosGeo Karnos Posts: 161Ansys Employee

    Hi yugiohmumi

    You can start our software with following switch: 

    -UseElectronicsPPE


    Best,

    Geo

  • mmadoremmadore Posts: 849Ansys Employee

    @yugiohmumi the solution is actually valid for Linux GUI as well, it wasn't clear you were requesting command-line options from your initial post. You can add the flag "-UseElectronicsPPE" to your command line to achieve the same result.

  • plubbsplubbs Posts: 1Member

    I am currently working on implementing support for Electronics PPE in our environment with yugiohmumi and found that users can submit Slurm jobs with the "-UseElectronicsPPE" flag with your help. However is there a way to set that option as a default on the Linux license server side in a configuration file under $PATH/ansys/shared_files/licensing in the 2021 R1 software? Ideally I'd like to allow users to submit jobs without having to include that command flag in their commands and just make it available at the license server level on my instance.

  • mmadoremmadore Posts: 849Ansys Employee

    @plubbs This is possible to set at the install level of the AnsysEM install. I'll be reaching out to you directly with some additional details.

  • yugiohmumiyugiohmumi Posts: 8Member

    As ANSYS experts suggested, we added an extra/default XML file to force the PPE usage.

    The problem is resolved now.


    Thank you all for the assistance.

Sign In or Register to comment.