Connecting to an external license server

jamiemjohnstonjamiemjohnston Member Posts: 1

I have Ansys Fluent, and workbench installed on an HPC, and a license server connected elsewhere.

There's another instance of Fluent running on a third machine, that will connect to the license server and validate properly. However, on our HPC we get an error when trying to connect to the same server.


My license file 'ansyslmd.ini' is stored in in /ansys/shared_files/licensing and the contents are:

SERVER=1055@{hostname}

ANSYSLI_SERVERS=2325@{hostname}


I found the instructions to connect to the server here: https://forum.ansys.com/discussion/5736/configuring-linux-client-in-command-line-mode-to-remote-license-manager-server


The HPC can resolve the hostname on the licensing server and It responds to ping, so it’s not a firewall issue, or anything preventing connection to the server that we can tell.

Answers

  • mmadoremmadore Posts: 849Ansys Employee

    @jamiemjohnston a successful ping of the license server doesn't rule out firewall or other connection restrictions. To test the access, you can use one of these options, please try for the lmgrd port, ansyslmd port and ansysli_server port, modify the command to replace "192.168.0.1" with the license server hostname.

    Telnet 192.168.0.1 1055

    nc -v -z -w2 192.168.0.1 1055

    (echo >/dev/tcp/192.168.0.1/1055) &>/dev/null && echo "Open 1055" || echo "Close 1055"


    Please make sure the port for the ansyslmd daemon is on the license server firewall. Starting with 2021R1 the applications must communicate through ansyslmd and lmgrd, where past releases used lmgrd and the ansysli_server process on 2325.

    You can set ansyslmd to a static port by adding it in the license file on the VENDOR line.

    For example:

    VENDOR ansyslmd PORT=1056


    On the Client side, please make sure there are no firewalls that could be blocking the ansyscl process from communicating.

Sign In or Register to comment.