Why is the new Lumerical HEAT not running well?

chuanxchuanx Member Posts: 2

I have just started using Lumerical 2021 R2 (the version I've been using before this was 2019b), and I have some trouble with HEAT. Models that ran in the older version now don't run in this new version. The meshing part is fine, but when it gets to initialization, the text turns red and the program stops. The error message just says the program has crashed. I had this issue occasionally with the older version as well, but by playing with the meshing settings, it usually disappears. For this new version, it appears to be more difficult to get around. Also this new programs seems to take a very long time "initializing" even when it eventually runs w/o error. I wonder what is going on and how do I get around the problem.

Incidentally, the graphics in the new version looks strange in wireframe view. There are extra lines that make the graph hard to read.

Regards,

Chuan

Best Answer

  • gsungsun Posts: 953Ansys Employee
    Accepted Answer

    The new version has used new geometry building technique so some issue can happen. I would suggest that you reset up the model from a clean new project file. Unfortunately right now the FEM GUI does not support copy and paste.

Answers

  • chuanxchuanx Posts: 15Member

    By the way, when the program is stuck at "initializing" the CPU usage if next to nothing. Makes you wonder what the program is doing, or waiting for.

  • chuanxchuanx Posts: 15Member

    Thanks @gsun . I'll try it. Not an easy solution, but it'll be worth it if it works.

    Chuan

  • chuanxchuanx Posts: 15Member

    @gsun I try to build a model in the new release from scratch, but run into another problem: when I try to partition the structure I get this error

    After some experiments, I realized that once the number of domains goes above 10 or 11, adding another object is going to trigger this problem (partition has not issue with fewer objects). What is the solution here? Appreciate a prompt guidance.

    Regards,

    Chuan

  • gsungsun Posts: 953Ansys Employee

    Maybe you need to have a little overlap between to geometries, in particular if there is sphere or cylinder.

  • chuanxchuanx Posts: 15Member

    No, that does not solve the problem. All the geometries I have so far are rectangular prisms.

  • chuanxchuanx Posts: 15Member

    @gsun Although I still have the problem that partitioning fails if I have too many objects (seems to limit to 11 domains), I tied to run HEAT with a half-compiles model. The super long pause after meshing does seem to disappear.

    Now the question is: how do I get around this limit on the number of domains? Also, why the file I made in the older version of Lumerical does not have this partitioning challenge when running with the current version?

    Chuan

  • gsungsun Posts: 953Ansys Employee
    edited August 20

    Hi @chuanx , I do not think the partition has limit, since it is the material interfaces. There might be other issues. As I mentioned, we have changed to a new geometry builder, so issues can happen. Please check your wall message.

  • chuanxchuanx Posts: 15Member

    Ok. Do you want me to send you the file so you can take a look?

  • chuanxchuanx Posts: 15Member

    I tried to upload the file, but it is too big. Anyway I can share the design model?

  • gsungsun Posts: 953Ansys Employee

    Sorry, even you can upload your file here, we are not allowed to open due to regulations. But you can paste screenshots about the structure, and simulation settings.

  • chuanxchuanx Posts: 15Member

    @gsun Here is some updates on this topic. When I disable the metal group in my structure, I get partition error:

    when I also disable the MZI group, partition works:

    What's more intriguing is that if I enable both the "MZI" group and the "metal" group, partition works:

    This at least explained one "mystery": why my model built in the older version of Lumerical does not have the partition issue.


    Chuan

  • gsungsun Posts: 953Ansys Employee

    I guess it is due to background material. For example, this file has SiO2 as background material:

    If no background material is chosen, and no cover material like (all device is inside this material)

    When you disable some objects, their original space is empty without material, then you will get the error message.


    Please check if it is due to this reason.

  • chuanxchuanx Posts: 15Member

    @gsun I tried with background material (SiO2) or w/o background material (none) for the simulation region, and it makes no difference.

    BTW, the object groups I disabled are embedded in SiO2 anyway, so disabling them will not leave a void.

  • gsungsun Posts: 953Ansys Employee

    Then check round objects and very small objects. Somehow the software cannot build up the geometry into the solver.

  • chuanxchuanx Posts: 15Member

    The dimension difference between the objects is quite large indeed. The Si waveguide layer is only ~160nm thick. The SM waveguides are 350nm wide. The other features, however, can be tens, even a couple of hundred microns in dimension. Would this be a problem? When you say very small objects, how small is small? The smallest dimension is 162nm.

    Also, this does not explain why adding the metal group, which are a bunch of Cu pieces, makes partition to work.

  • chuanxchuanx Posts: 15Member

    When volume partition works, there isn't even a warning:

    Chuan

  • gsungsun Posts: 953Ansys Employee

    when you have thin but long geometry, the meshing to have a quality finite element may have problems. You may need to use local meshing to use smaller mesh size there.

    If the problem still exists, I would suggest that after disable some geometry, copy the active geometry to a new project. Or simple delete the disabled geometry. or build the device in a new project file. Currently I have not found any documentation about this error.

    Partition is the first step in meshing, to recognize the geometry in solver. It is also possible that in some case the software has a bug. If the error does not prevent to run the simulation, it is ok to continue the simulation to get result. If the simulation cannot continue, you may disable the objects outside the simulation region, or delete them. You may test it by disabling/enabling each of them and identifying which geometry/material causing this issue.

Sign In or Register to comment.