Cant import spaceclaim model into fluent mesher

I have a spaceclaim file that I'm trying to import into the fluent mesher but I get the following errors

importing meshing model from PartMgr from file 'H:\Part 4\GDP\Fluent Practice\Script-practice\Front-wing-script\straight-line.scdoc' failed.)

ran ANSYS TGrid CADToTGridConverter in 1.115 [s]

 

======== Command Execution Log Manager ========

 

Number of execution logs: 2

 

MeshingModelImportPartMgrExecLog

 

Label = 'ANSYS_MESH_FM_WARNING_ID_MESHINGMODEL_IMPORT_PARTMGR_ERROR'

 

 

 

DataTranslatorCommandExecLog

 

Label = 'ANSYS_MESH_FM_ERROR_ID_CONVERT_WORKBENCH_TO_FLTG_ERROR'

Error: Error in CAD Import

Error Object: #f

I have this error on any spaceclaim model I attempt to open (even a simple cube) and on models that I have already opened in the mesher. I get this error randomly, some days it will let me import spaceclaim models and some days it wont even when it is the same file being imported in the same way.

for reference the file I'm attempting to import is attached. 

Has anyone experienced this before or have any idea how to sort it?

Regards

Rikesh 

 

 

Comments

  • kkanadekkanade Forum Coordinator
    edited October 2018

    Hello, 

    Which version you are trying?

    Can you please use and install latest R19.2. 

    Regards,

    Keyur

  • rm19g14rm19g14 Member
    edited October 2018

    hello,

    thank you for your reply.

    I am using fluent 19.1 but cannot use 19.2 as I am using a university workstation and do not have access to that version.

  • RobRob UKForum Coordinator
    edited October 2018

    If it's random then it's likely to be IT related. Are you using a teaching or research licence? 

  • KremellaKremella Admin
    edited October 2018

    Hello,

    Quick questions:

    • are you seeing this error with any SCDM geometries?
    • have you tried importing a simple DM geometry?
    • could you try importing a generic file format - parasolid or stp and see if you are getting this error?

    please let us know what you find.

    Best,

    Karthik

  • rm19g14rm19g14 Member
    edited November 2018

    apologies for the late reply, I do believe it is an IT issue but my IT department doesn't seem to want to do anything about this. either way I found a work around. I can upload the geometry to the DM as you suggested then in the mesher export the meshdat file to import into the fluent mesher.

  • Sorry to resurrect an old string, but I am having this issue. When I try to transfer the model directly from SC to Fluent, I get the same errors. I have not been able to export the design to DM and then into Fluent as a workaround. When I save the SC file as a tgf and then try to import it into Fluent I get the same errors. I have been able to save the file as STP or IGES and then open those in Fluent, but I worry that I am loosing information that was originally contained in the SC model.


    Any recommendations on how to solve this? I am not allowed to run my program as an administrator, so solving issues that involve administrator privileges is going to require going through IT. That could make a real mess of things, but I understand if it's necessary.


    Thanks for the help.

    Brendan

  • Hello,

    Not sure if my case is comparable to the earlier question but I just encountered the same error when I tried to open a .scdoc file for meshing in Fluent.

    Error: Error in CAD Import

    Error Object: #f

    I was able to resolve it by saving the geometry file again as a new version. Since I was simulating different scenarios for the same geometry, I only have one 'root' file or original file (not sure what it's called but its all from one original file that I just modify). When I accidentally deleted the root file, I had the error, so I just redid it again and made sure the original file was safe. Now it works.


    Thank you,

    Christian

  • I have been having the same issue as Christian.

    If I use the Flow Flow (Fluent) workflow in Workbench R2 2020, I am able to import the geometry via that however, I am simply unable to import geometry directly into fluent using the Watertight Geometry workflow.

    Best, Potts

Sign In or Register to comment.