Workbench will not open. crashes with fatal error

mdawsonmdawson Member Posts: 1

Morning all, I'm getting a fatal error when opening Workbench. Here is what I have.

Ansys 2020R1


ANS_OLD_ATTACH 1 <SYSTEM>

ANSYS201_DIR C:\Program Files\ANSYS Inc\v201\ANSYS <SYSTEM>

ANSYS_SYSDIR winx64 <SYSTEM>

ANSYSLI_ELASTIC 0

ANSYSLI_LCP 0

ANSYSNCODE202_DIR C:\Program Files\nCode\ANSYS 2020 R2 nCode DesignLife 64-bit <SYSTEM>

AWP_ROOT201 C:\Program Files\ANSYS Inc\v201 <SYSTEM>

CADOE_LIBDIR201 C:\Program Files\ANSYS Inc\v201\CommonFiles\Language\en-us <SYSTEM>

ComSpec %SystemRoot%\system32\cmd.exe <SYSTEM>

DriverData C:\Windows\System32\Drivers\DriverData <SYSTEM>

ICEFLOW_ANSYS_PORT 9600 <SYSTEM>

LSTC_LICENSE ANSYS <SYSTEM>

NUMBER_OF_PROCESSORS 56 <SYSTEM>

OS Windows_NT <SYSTEM>

P_SCHEMA C:\Program Files\ANSYS Inc\v201\AISOL\CADIntegration\Parasolid\PSchema <SYSTEM>

Path %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Micro Focus\Reflection\;C:\Oracle\product\12.2.0\client_1\bin;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;%SYSTEMROOT%\System32\OpenSSH\;C:\Program Files (x86)\HID Global\ActivClient\;C:\Program Files\HID Global\ActivClient\;C:\Program Files\Tumbleweed\Desktop Validator\;C:\Program Files\Tumbleweed\Desktop Validator\x86;C:\Program Files\MATLAB\R2019b\runtime\win64;C:\Program Files\MATLAB\R2019b\bin;C:\Program Files\dotnet\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program Files (x86)\dotnet\; <SYSTEM>

Path %USERPROFILE%\AppData\Local\Microsoft\WindowsApps NT AUTHORITY\SYSTEM

Path %USERPROFILE%\AppData\Local\Microsoft\WindowsApps;%USERPROFILE%\.dotnet\tools

PATHEXT .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC <SYSTEM>

PROCESSOR_ARCHITECTURE AMD64 <SYSTEM>

PROCESSOR_IDENTIFIER Intel64 Family 6 Model 85 Stepping 4, GenuineIntel <SYSTEM>

PROCESSOR_LEVEL 6 <SYSTEM>

PROCESSOR_REVISION 5504 <SYSTEM>

PSModulePath %ProgramFiles%\WindowsPowerShell\Modules;%SystemRoot%\system32\WindowsPowerShell\v1.0\Modules <SYSTEM>

SW_SIM_HYDRA C:\Program Files\Common Files\SolidWorks Shared\Simulation Worker Agent\ <SYSTEM>

SW_SIM_MPIT INTELMPI <SYSTEM>

SW_SIM_TEMP C:\ProgramData\SOLIDWORKS\SW_net_sim_temp\ <SYSTEM>

TEMP %SystemRoot%\TEMP <SYSTEM>

TEMP %USERPROFILE%\AppData\Local\Temp NT AUTHORITY\SYSTEM

TEMP %USERPROFILE%\AppData\Local\Temp

TMP %SystemRoot%\TEMP <SYSTEM>

TMP %USERPROFILE%\AppData\Local\Temp NT AUTHORITY\SYSTEM

TMP %USERPROFILE%\AppData\Local\Temp

UATDATA C:\windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77 <SYSTEM>

USERNAME SYSTEM <SYSTEM>

windir %SystemRoot% <SYSTEM>

XERCES_DISABLE_DTD 1 <SYSTEM>

Answers

  • Geo KarnosGeo Karnos Posts: 504Ansys Employee

    @mdawson

    Workbench localization files (*.ts files) are XML files. Most of them contains, usually at the 2nd row, a line starting with something like this: <!DOCTYPE TS

    This line is not necessary although it is added when these localization files are auto-generated.

    The line is the basic form of DTD therefore is unrecognized when the customer disable DTD processing.

    We will try to remove this line in our .ts files for future releases.

    For now, disabling DTD processing is the only option

Sign In or Register to comment.