Fluent 2021 R1 running on a linux server has issues with Intel MPI 2018

I am trying to run cases in Fluent on a remote linux server via GUI. When fluent loads it gives the following message in the text interface:


Host spawning Node 0 on machine "d0147" (unix).

/shared/centos7/ansys/2021-R1/ansys_inc/v211/fluent/fluent21.1.0/bin/fluent -r21.1.0 3ddp -flux -node -alnamd64 -t32 -pinfiniband -mpi=intel -ssh -mport 10.99.101.147:10.99.101.147:43661:0


-------------------------------------------------------------------------

Intel MPI 2018 may not work due to DAPL deprecation in Mellanox OFED 5.1

 * Use -pib.ofed in such case.

-------------------------------------------------------------------------


Has anyone encountered this error before, or does anyone know what could be causing this? Additionally, does anyone know how or where I would specify the -pib.ofed tag? Since I am using a GUI I don't type the command to launch Fluent.


Thanks,

Bjorn Kierulf

Answers

  • huwanghuwang Posts: 26Forum Coordinator

    Check latency and bandwidth in Fluent GUI > Parallel, if latency values are lower than 3 and bandwidth values are higher than 3GB, IB with DAPL should still work.

    To force to used OFED (ofa farbrics for Intel MPI 2018), try to add -pib.ofed when launching Fluent launcher, also add -mpiopt="-genv I_MPI_DEBUG=2" as below to print Intel MPI debug info.

    /shared/centos7/ansys/2021-R1/ansys_inc/v211/fluent/bin/fluent -pib.ofed -mpiopt="-genv I_MPI_DEBUG 2"

    in Fluent launcher GUI > Parallel Settings > Interconnects, it should show ib.ofed, also in Fluent Console (after it's launched), it should print Intel MPI fabrics info:

    ...

    MPI startup(): shm and ofa data transfer modes

    ...

Sign In or Register to comment.