How to have a specific sampling rate for results in a transient analysis with auto time stepping on?

CW62CW62 Member Posts: 9

Dear Ansys Forum Users,

I wish to have a sampling rate of 2000 Hz for the results of a transient analysis in Ansys Mechanical. I have tried to use a fixed time step of 5e-4 s; however, the model fails to solve due to this time step being too large. I have therefore activated automatic time stepping with an initial time step of 5e-4 s, a maximum time step of 5e-4 s and a minimum time step of 1e-12 s. The model solves using automatic time stepping.

I have used the following commands to specify output of nodal solution results at a sampling rate of 2000 Hz for a 5 s simulation:

OUTRES,ERASE

OUTRES,ALL,NONE

OUTRES,NSOL,-10000

Unfortunately, the results I get are not at an exact sampling rate of 2000 Hz. The time step between each result isn't always 5e-4 s, which is what I require. Does anyone know what settings I need to specify to ensure the results output I have requested is given at specified sampling rate?

Thank you for any help.

Best Answer

  • peteroznewmanpeteroznewman Posts: 12,786Member
    Accepted Answer

    @CW62

    I don't know how to force ANSYS to do an exact resampling of the results.

    I use matlab to read in results with a varying time increment over the simulation time and interpolate to a perfectly regular time increment that I can write out.

Answers

  • CW62CW62 Posts: 12Member

    @peteroznewman

    Thank you for your suggestion. I was considering just using the resample function in matlab to do exactly as you describe, but I noticed that Abaqus will output results at a specified sample rate even when using auto time stepping and so I wanted to check if it was possible in Ansys. Thanks again for your help!

Sign In or Register to comment.