Mesh sizing - 2 bodies - Fluent Meshing

shadowfax7shadowfax7 Member Posts: 9

What I'm trying to do: meshing a small body embedded in a large body. Because I need to determine the ideal sizing of the two bodies, I first run a mesh independence study for the large body without the small body embedded in it. From this, I determine the ideal sizing parameters (min/max size of surface elements, max cell length of volume elements) in Fluent Meshing - Watertight Workflow. Then, I want to embed the smaller body in the larger body, and play with the mesh density of the smaller body to determine its ideal sizing. However, this is where I run into trouble. When I open my geometry (smaller body embedded in larger body) in Fluent Meshing, I define a "body sizing" for my smaller geometry and give in the sizing parameters for my larger body as previously determined. What I see now is that the mesh density of my larger body has changed, even though I didn't change the parameters. I don't understand what's going on. Below you can see two pics: the first one is the smaller body embedded in the larger one, but without defining a body sizing for the smaller body. In the second pic, I've defined a body sizing for the smaller body, and you can see how the mesh density of the larger body has changed (even though the sizing parameters remained the same). Any ideas on how I can keep the original mesh density of my larger body?


Answers

  • kkonannavarkkonannavar Posts: 12Ansys Employee
    edited November 26

    Hello

    Could you please add screenshots of the settings you use in the workflow while doing the different mesh sizing operations, just to get a better picture as to how you go about the sizing operations.

    Thank you.

    Regards

    Kishan

  • shadowfax7shadowfax7 Posts: 17Member

    Hi

    Thanks for your response. Screenshots below for surface mesh & volume mesh settings. I adapt min/max sizing of surface mesh & max cell length of volume mesh. Transition ratio, growth rate, etc. are kept constant. These surface/volume settings are the same for each mesh. For the mesh without body sizing, this results in a total number of elements of 8 million.


    Once I add a body sizing for the smaller body, (3rd screenshot) the total number of elements decreases to 2.7 million. Overall settings stay the same, only parameter that “changed” was body sizing. I understand that there could be a small change in number of elements (adding the small body with a different sizing will also alter elements near the small body) but I don’t understand why this decrease is so large? As I stated above, it doesn't look like the same mesh anymore.


  • kkonannavarkkonannavar Posts: 12Ansys Employee

    Could you try adding local sizing to the larger body too with the appropriate mesh size and generate the mesh?


    Regards

    Kishan

  • shadowfax7shadowfax7 Posts: 17Member

    First screenshot: one body sizing for the larger body; second screenshot: two body sizings, one for the larger body and one for the smaller body. At least the mesh sizing parameters are consistent now. However, since local controls override global settings, this means that the rest of the workflow (surface mesh sizing, volume mesh sizing, etc) is now practically useless?


Sign In or Register to comment.