Unable to visualize the sweep results for electric field and magnetic field

emh711emh711 Member Posts: 13

I did a sweep.

I was able to visualize the sweep result for transmission.

But, I was unable to visualize the sweep results for electric and magnetic fields.


What is the reason that I am unable to visualize the sweep results for electric and magnetic fields?

What should be done to fix the problem?

Comments

  • trobertstroberts Posts: 111Ansys Employee

    Hello,


    The reason for this is likely that the matrix size of the fields as changing as you increase the simulation span. The simulations have run, and they have results, it is just that when the sweep tries to create a dataset of the resulting E, H field matrices by stitching them together there is a dimensional mismatch. If you reload the results you should see an error.

    https://support.lumerical.com/hc/en-us/articles/360034922933

    I would make the monitors smaller than the simulation span, and ensure the mesh is consistent between simulations even as you add mesh cells at the boundary. If the results, have the same geometric extent, and mesh cell number there should be no issue. The transmission is measured across the entire monitor, and will therefore not be sensitive this grid mismatch issue.


    Best,

  • emh711emh711 Posts: 30Member

    I tried the method that you mentioned.

    I made the monitor smaller than the simulation span.

    I am still unable to obtain the sweep results of E and M fields.

    I am not sure how I can make sure the mesh is consistent between simulations since the x span and y span of FDTD simulation span change between simulations.

    That would have caused inconsistency of the mesh.

    What is your suggestion of what I should do next to fix this problem?

Sign In or Register to comment.