the density of the Composition PDF Transport model

study_CFDstudy_CFD Member Posts: 2

Hi all,


I was hoping someone might be able to help me with an issue I've been having for a while when trying to run the Composition PDF Transport model to simulate a turbulent combustion problem.


Previously I used a different combustion model (EDC) with no issues, however, when changing to the PDF model I get the following error:


"999999: mpt_accept: error: accept failed: No such file or directory


MPI Application rank 0 exited before MPI_Finalize() with status 2


The fl process could not be started."


The weird thing is that this error only occurs when the density is set to "ideal-gas" in the Edit Material panel (i.e. it is fine with either "incompressible-ideal-gas" and "volume-weighted-mixing-law"). I've also tried it with a simplified version of the model using the default mixture template and the same error occurs when setting the density to "ideal-gas" rather than incompressible.


I should also mention that this error only occurs when the Lagrangian option is selected for the PDF Transport, and it seems to be fine when Eulerian is selected. It also occurs whether the simulation is run in serial or parallel.


I'm not sure if this is a bug with Fluent or there is something I'm doing wrong, but I'd appreciate any help with this, thanks.

This discussion has been closed.