getting an error in CFD fluent solver. It is a multiphase Eulerian model with DPM iteration.

KukiKuki Member Posts: 1

Divergence detected in AMG solver: epsilon

DPM Iteration ....

number tracked = 1, escaped = 0, aborted = 0, trapped = 0, evaporated = 0, incomplete = 1, incomplete_parallel = 0


turbulent viscosity limited to viscosity ratio of 1.000000e+05 in 1957 cells


Error at host: floating point exception


Error at Node 0: floating point exception


===============Message from the Cortex Process================================


Compute processes interrupted. Processing can be resumed.


==============================================================================


Error: floating point exception

Error Object: #f

Answers

  • nnaralennarale Posts: 13Ansys Employee
    edited January 13

    Hello,


    With this information, it is hard to comment. Can you share more details on the setup like boundary conditions, models and the solver settings?


    However, Here are few things you may try.

    1: Check if the mesh quality is within the acceptable limits. If not, try resolving the mesh.

    2: Try reducing the URF for k and epsilon. If the solution tends to converge, ramp it up to the original value.


    I hope this helps.


    Nikhil

  • KukiKuki Posts: 2Member

    Dear Nikhil,

    I have tried to correct the mesh quality but it didn't worked. I haven't tried reducing the URF yet.

    I am using Eulerian dense discrete multiphase model(as want to simulate water +abrasive) inside a nozzle. K-Epsilon standard equation with enhanced wall treatment.

    Boundary conditions- Inlet pressure is 40MPa and at outlet it will be atmospheric(so taken gauge as 0). Turbulence intensity as 5% and hydraulic diameter as 0.65mm.

    For the solver setting I am using Phase Coupled scheme. pressure in PRESTO, and turbulence kinetic energy-turbulence dissipation rate as first order.

  • RobRob UKPosts: 12,322Forum Coordinator

    400bar pressure loss? I suspect your problem is down to the shock interactions and the multiphase solver isn't going to work well in those conditions.

Sign In or Register to comment.