Error: The UDF library you are trying to load is not compiled for 3d on the current platform (win64)

Hello,

I cant compile my udf . I have ANSYS Release 18.0. I looked other posts but still I have same problem.

 

https://studentcommunity.ansys.com/thread/problems-loading-udf-for-moving-mesh-in-fluent/

according to this post, I installed  Visual Studio Community 2015 and SDK. But nothing changed.

Do you have any suggestions?

Comments

  • DrAmineDrAmine GermanyForum Coordinator
    edited January 2019

    SDK is not really required here. Just open x86_46 Cross Tool Command Prompt from VS Program launch Fluent from there, try to compile. 

  • kadimtalebekadimtalebe Member
    edited January 2019

    I tried that but Still I have same problem.

  • DrAmineDrAmine GermanyForum Coordinator
    edited January 2019

    Make a clean uninstall of all VS releases and SDK. Install VS once again as admin and try again. I

  • kadimtalebekadimtalebe Member
    edited January 2019

    Am I doing it right? and thank you for your all reponse.

  • kadimtalebekadimtalebe Member
    edited January 2019

    I solved the problem.I applied this:

    "Set the correct environment variables. Browse your way through the Windows system control to 'System'. There you will find a section 'Advanced system settings'. In the following dialog go to the 'Advanced' tabulator and click on 'Environment variables' (lower right corner). Go through the 'System variables' list and search for the 'Path' entry. Add the following to the variable: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files\ANSYS Inc\v120\fluent\ntbin\win64"

    In my system it is like this: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;C:\Program Files\ANSYS Inc\v180\fluent\ntbin\win64

    Then, problem is solved.

  • MartitaMartita Member
    edited April 21

    Hi!

    I have the same problem, did you create a new variable or did you edit one of the existing variables??

  • kadimtalebekadimtalebe Member
    edited April 21

    Hi Martita!,

    I am not sure but as far as I remember, I found the path from system variables then I added a new variable.

  • MartitaMartita Member
    edited April 21

    With a random name?

  • kadimtalebekadimtalebe Member
    edited April 21

    Ah ok, I think I got it now.

    find the path and click "edit". Then paste the way.

    sorry for the previous misdirection

  • MartitaMartita Member
    edited April 21

    Thank you!! I have solved the problem

  • attiqattiq Member

    I am facing this error (statement below) How to get it off?

    Error: The UDF library you are trying to load (libudf) is not compiled for parallel use on the current platform (win64).\n\nThe system cannot find the file specified.

    \n\nC:\Users\HP 15 BS\Desktop\Dynamic Mesh Practice_files\dp0\FFF\Fluent\libudf\win64\2ddp_host\libudf.dll

    Error Object: #f

Sign In or Register to comment.