License Error

shconshcon Member Posts: 15

Hello, I recently tried to install our new license on the license server (Windows OS).  In order to do so, I make a necessary edit to include the correct port number and change the file extension to '.lic'.  Is this correct?  Also, previous files had license-ansoft__.lic in the file name thisyear the file received had license- ansys_hybrid___.txt.  Could that be the problem?  The VENDOR listed in the file is also different from last year's file (ansyslmd has never been the VENDOR before this year).  I cannot allow the ANSYS License Manager to delete the software currently being used to manage the license because it is used for other licensed products.  Please advise if there could be an error with the file (did we receive the correct license). Please see below for the error messages:

Error rcvd when trying to run HFSSError rcvd when trying to run ANSYS Electronics Desktop 18.2

«1

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited March 2019

    Hi shcon,

    You received the correct license. Now we don't issue separate Ansoft license file anymore, everything is under ANSYS license file with ANSYS vendor daemon (ansyslmd). I would recommend to just use ANSYS License Management Center GUI to 'install' the license file and start/stop (manage) the ANSYS License Manager. Our License Manager can co-exist with other licensing tools (which I believe most if not all of them are FlexNet based).

    In ANSYS License Management Center GUI, you can also check the FlexNet Debug Log and make sure that the License Manager is up and running.

    Once this is done on server side, on the client side, you must make sure that the SERVER line in the C:\Program Files\AnsysEM\admin\redirect.lic file has the FlexNet port at the end , for example

    SERVER <server_hostname> ANY 1055

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited March 2019

    Hello Win,

    Thank you for your reply.  I will give your suggestion a try.

     

    Regards,

    Shcon

  • shconshcon Member Posts: 15
    edited March 2019

    Hello Win,

    I am now receiving "Failed to check out license 'hfss_desktop'.  Cannot connect to license server (FLEXlm Error -15)"  Can you please tell me how I can get a newer ansyslm.exe file? 

     

    Thank you,

    Shcon

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited March 2019

    Hi Shcon,

    You are now having a different issue.

    The client machine (AnsysEM) can't communicate with the license server machine.

    Check the followings:

    1. Make sure license server is up and serving licenses correctly.

    2. Client is pointing to correct server in redirect.lic file

    3. Client can communicate to the server via 1055 and ansyslmd ports with the hostname specified in redirect.lic . You can test the communication using telnet command , e.g.,

    telnet <hostname> 1055

    telnet <hostname> <ansyslmd_port>

    Note that your machine may not have telnet feature turned on. You can turn it on by typing Windows features in "Search Windows" tool box , then look for "Turns Windows features on or off" and launch this. Then, scroll down to the bottom and check "Telnet Client" > OK

  • shconshcon Member Posts: 15
    edited July 2019

    Hello Win,

    I cannot communicate with the server and the port number.  Are the 1055 and port number required?  I think I may have entered to port number incorrectly.

     

    Thanks,

    Shaynee

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited July 2019

    Hi Shaynee,

    Yes, client communicates with server via two TCP ports. FlexNet (lmgrd) uses 1055 by default (this is what you see in your license file) and the ANSYS vendor daemon (ansyslmd) uses dynamics port by default but you can set it to be static by modifying the VENDOR line in every your installed license (.lic) files

    so that it looks like this

    VENDOR ansyslmd PORT=1056

    This will force ansyslmd to always run on 1056. You can change the port number to anything you like.

    You have to make sure that these two ports are open between client and server. Note: On the client side, in redirect.lic file, you only need to specify the FlexNet port (1055 default).

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited July 2019

    Hello Win,

    I added the port number on the VENDOR line and receive Flexlm -96 as the error when I try to open HFSS on a client machine.  What version of HFSS will work with the ANSYS License Manager Release 2019 R2?  I have the Electronics Workbench 18.2 installed on a different client and that will not open either.  

    The license file has

    SERVER <server name> ANY 27002

    USE_SERVER

     

    and the license file has

    SERVER <server name> MAC address port number

    VENDOR ansyskmd PORT=1056

    USE_SERVER

     

    Are any of the lines above incorrect?  When I try to start the license manager, the message states the license server has been successfully started but the STOP sign is showing instead of the green check mark.  Also can you elaborate on what is meant by "Set Site Preferences"?  I select an option and the GUI does not open and I get "Could not make an SSL handshake with server [email protected]  Connection timed out while handshaking with server."   Why is the port number 2325?  Is there a way to setup the license server without using the Interconnect?

     

    Regards,

    Shaynee

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited July 2019

    Hi Shaynee, 

    Where did you see this 'Set Site Preferences' ? You should not need this part for License Manager or Client side licensing for the Electronics desktop (AnsysEM) products.

     

    In the license file on your license server

    ------------

    SERVER server MAC address port number

     

    VENDOR ansyskmd PORT=1056

    USE_SERVER

    ------------

    what is the 'port number' at the end of the SERVER line ? This is the port that the client redirect.lic file should be specifying, which seems like you are specifying 27002.

    please also verify that this ansyskmd is a typo of ansyslmd

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited August 2019

     Hello Win,

    When ANSYSLICMAN_2019RD_WINX64.zip was extracted and the license manager installed, the options below are what were available for managing the license.   The Set License Preferences is an option in the Server ANSLIC_ADMIN utility

     

    screenshot of ANSLIC_ADMIN

    screenshot of ANSYS License Mgr

     

    In the ANSLIC_ADMIN GUI, I entered the host name and the port.but I see the following:

    screenshot after host name and port # are entered

    that's the 2325 I was asking about.  The port number at the end of the server line in the license file is 27002.  From your reply, it sounds like I am not using the correct software for license management or the EM software.  I do not have Flexlm software installed and when I select lmgrd.exe (it's listed in ANSYS Inc\ win64 folder after installation), the cmd prompt window flashes and then nothing.   Yes, my apologies, that was a typo on my part.

    Due to some campus-wide changes, I no longer have administrative privileges for most of the client machines that need the license; therefore, I cannot install any new software.  Before I can proceed, I need the server to work.  The machine that has the Telnet Service enabled returns: "Could not open a connection to the host on port 23: Connection failed."

    Please advise what my next steps should be; thank you.

     

    Regards,

    Shaynee

     

     

     

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited August 2019

    Shaynee,

    Thanks for the info. You don't have to worry about the Server ANSLIC_ADMIN Utility tool. This tool is rarely used nowadays (there are some customization that can be done here but 99% of the time, you don't need to customize it). You can directly launch ANSYS License Management Center GUI and mange the license server in this tool.

    The main issue here is that only the ANSYS Licensing Interconnect is shown as running (this is from your ANSYS License Management Center screenshot). Your FlexNet Licensing is actually down. Please click on the 'View Licensing Interconnect Log' , scroll to the bottom and take screenshot and post it here. Also, click on the 'View FlexNet Debug Log' , and see if there is any line that says 'error'

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited August 2019

    Hello Win,

    Here are screenshots from the License Management Center and the license.log file.

    LMC1

    LMC2

    license_log_file_error

    It appears the time is incorrect in this file if 00:006 is 36 seconds after midnight.  The time should be 1:05 pm.  Should I remove the port number after ansyslmd in the license file?  I do not have FlexNet software...

     Here is another screenshot...LMC3

    Regards,

    Shaynee

     

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited August 2019

    Shaynee,

    You don't have to remove the port number but you have to make sure the port is available and is not blocked by anything.

    Also, you may have to make sure there is no stuck processes running. Kill all of these processes: ansysli_monitor.exe, ansysli_server.exe, lmgrd.exe (for ANSYS only), and ansyslmd.exe. Then try starting the License Manager again and check the FlexNet Debug log. 

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited August 2019

    Hello Win,

    FlexNet Licensing is running...had to do the taskkill twice for some reason.  I'm still getting the Flexlm -96 error when I try to open HFSS15 on another computer.

     

    Regards,

    Shaynee

     

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited August 2019

    Hi Shaynee,

    Can you confirm that other, newer versions are now working ?

    You probably can't get HFSS 15.0 to work. It requires certain license feature that has already been retired. Your current license file should not have this license feature anymore (this is called hfss_desktop). I would note that this does not result in Flex -96 error, but even if you get past this Flex -96, you are going to end up with Flex -18 because hfss_desktop does not exist in your license file. 

    Thanks,

    Win

  • shconshcon Member Posts: 15
    edited August 2019

    Hello Win,

    I was able to get a version of ANSYS Electronics Desktop to work on a different lab's computer.  It appears that I will have to get the EM software updated.  When you have a chance, can you let me know the correct software or whether ANSYS Electronics Desktop is sufficient?

    I really appreciate your help throughout this process.  I also thank you for troubleshooting the problems I had with the new license manager.

    THANK YOU!!!!!

    Regards,

    Shaynee

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited August 2019

    Hi Shaynee,

    Sounds good and you are welcome. The AnsysEM (AEDT) version 16.2 or newer is good with current license file. Generally, I would recommend you to use AnsysEM at least in 2019 R1 version. Please note that the licensing mechanism's changed for AnsysEM 2019 R2 vs AnsysEM 2019 R1 or older AnsysEM versions. 

     

    Starting from 2019 R2, the AEDT (Ansoft) licensing has been changed to make it one step closer to ANSYS products (like Mechanical, Fluids, etc.) licensing.

    The following ways to specify license servers will NOT work anymore

    LM_LICENSE_FILE=<FlexNet_port>@&lt;server>

    ANSOFTD_LICENSE_FILE=<FlexNet_port>@&lt;server>

    (default location) C:\Program Files\AnsysEM\admin\*.lic 

    /AnsysEM/admin/*.lic

    with content like

    SERVER <server> ANY <FlexNet_port>

    USE_SERVER

     

    Here are the ways to specify license servers starting from 2019 R2

    ANSYSLMD_LICENSE_FILE=<FlexNet_port>@&lt;server>

    (default location) C:\Program Files\AnsysEM\Shared Files\Licensing\ansyslmd.ini 

    /AnsysEM/shared_files/licensing/ansyslmd.ini

    with content like

    SERVER=<FlexNet_port>@&lt;server>

     

    Note: These changes are all client side. So, you don't need to update the binaries version or anything on the license server side.

    Note2: These can co-exist with older AEDT versions and any ANSYS versions.

     

    Let us know if you have any question.

    Thanks,

    Win

  • jepolqwerty14jepolqwerty14 Member Posts: 2
    edited August 2019

    Hi, I'm having issue as well, i cannot open save file from the outside directly, for example i want to open the scdoc file from desktop, error prompt once double click,

    and the logo became different as well, it becomes like old version

    please see attached photo

    this is what it looks like when directly open from the outside

  • jepolqwerty14jepolqwerty14 Member Posts: 2
    edited August 2019
  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator Posts: 3,071
    edited August 2019

    I can't see the images but I'm guessing you have a Windows file association issue.

    Please create a new thread for your own issue but this is mostly Windows issue.

     

  • redantredant Member Posts: 15

    Hi, Tsiriaks.

    It solves my problem. Found that the another process was working and occupy 2325 port.

    I working through VPN and firewall opened with port 1055 and 2325.

    You need firstly check the Flexnet debug log. Check there the ansyslmd listening port (2325) that you setupped in ANSYSLIC_ADMIN and lmgrd listening port (1055).

    If not, then unload License manager and all processes with ANSYS product in Windows Task Manager( CTRL + SHIFT + ESC).

    After that restart License manager again. Must be work.

    Additionally check connection in Client machine by using CMD and command line

    "C:\Program Files\ANSYSEM\Shared Files\Licensing\winx64\lmutil" lmstat -a -c [email protected]<server>

    Note: Replace <server> with actual server information (hostname, fqdn, or IP address). In my case the lmutil was in ... ASYSEM ... folder.

    It should show the list of licenses and then the connection to server is ok.

    see https://forum.ansys.com/discussion/19683/license-server-on-aws

    I spent whole 1.5 days to solve this problem.


    Thank you

    ANton Lukyanov

Sign In or Register to comment.