Two different meshs on the same object

RobertoLucenaRobertoLucena Member Posts: 11

Hello,

I´m trying to analyse a tank storage, but when I run the simulation the following error appears:

"Linear Tetrahedral elements have been used in regions with linear materials. This is not recommended. Please consider changing your mesh settings to use a different element type in these regions."

When I try to change my mesh, I´m unable to change just one region of my modelation. How Can I solve that?

 

Comments

  • peteroznewmanpeteroznewman Posts: 11,404Member
    edited March 2019

    Click on Mesh, and in the Details window, change Element Order to Quadratic.

  • RobertoLucenaRobertoLucena Posts: 37Member
    edited March 2019

    When I do that, my "Element Order" is blocked, like this:

    It is gray and I cant change it

  • peteroznewmanpeteroznewman Posts: 11,404Member
    edited March 2019

    That is because you have selected a specific element, a good one for this model, the SOLSHELL190, which only comes in Linear order.

    The message you got was a warning, not an error, is that correct?

    One thing you could do is slice the geometry so make three sweepable bodies. For example, slice at the inside wall of the top and bottom planes, then put the three pieces in a multibody part by picking the three bodies and RMB to Form New Part. To continue to use Solid Shell elements, you must select the Source face as the inside face of the thin wall sweep. That is because the a Solid Shell element needs to know which direction is the "thin" direction. Once you do this, you can also set the number of elements to sweep to 2 or 3 elements.

  • RobertoLucenaRobertoLucena Posts: 37Member
    edited March 2019

    Yes, is just a warning, but I dont understand why this simulation isnt returning results. I didnt put any loads yet, but just the self weight should give some results.

  • peteroznewmanpeteroznewman Posts: 11,404Member
    edited March 2019

    Do you mean you didn't put any other loads yet, besides Gravity, which is a load?

    I don't know why you got zero deformation, but you haven't shown all the loads and supports on your model. Maybe you should take the warning seriously and do what I suggested with the mesh.  If you don't want to slice the geometry, you could just change from Manual Thin to Program Controlled and set the Element Option to Solid, then you will be able to select Quadratic Element Order.

     

  • SmeetSmeet Posts: 4Member
    edited March 25

    I have a similar error (different geometry from the question), I tried changing to quadratic but it doesn't mesh anymore and results in errors.

    Any other options?

  • peteroznewmanpeteroznewman Posts: 11,404Member

    @Smeet

    Is the geometry a thin-walled part, with mostly constant wall thickness? If so, convert the geometry from a solid model to a midsurface model using the midsurface button in SpaceClaim.

    Otherwise, slice the geometry up into smaller uniform sections, ideally six-sided pieces.

Sign In or Register to comment.