Fluent 19.2 fails to fully load

Hello and thanks in advance to anyone who takes the time to read. 

 

Fluent 19.2 starts to load, then I get this: 

      Host spawning Node 0 on machine "P52-PC" (win64).

      WARNING: No cached password or password provided.

               use '-pass' or '-cache' to provide password

and then it gets stuck. If I was trying to start it from Workbench I also get the error "the fluent application failed to start". 

 

I'm on Windows 10 and on an administrator account, which has no spaces in the name. The Ansys Student installation was done as administrator. It's a new laptop with no previous installations of Ansys. 

I tried reading other threads; here's some stuff that I've tried. 

  • I tried starting Fluent with different processing options. Parallel w/ 0 processes STARTS; Serial and Parallel w/ 2 FAILS. 
  • I tried disabling Defender, then disabling the Firewall, then disabling both at the same time. FAILS in each case. 
  • I tried starting Fluent from the command prompt with "C:\Program Files\ANSYS Inc\ANSYS Student\v192\fluent\ntbin\win64\fluent.exe" ^-r19.2.0 3d -meshing       FAILS
  • I tried starting Fluent from the command prompt with "C:\Program Files\ANSYS Inc\ANSYS Student\v192\fluent\ntbin\win64\fluent.exe" ^-r19.2.0 3d -g -meshing     FAILS in the same way (prints the same warning in the cmd window)
  • Opening from Workbench or from Start menu both FAIL. 
  • I tried rearranging the contents of the PATH system variable (not the user one) to move the paths starting with C:\Windows on top. Still FAILS. 

 

I would appreciate any suggestions and help. 

Thanks

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 2019

    Hi pizzazzlous,

    You did a great homework ! Thank you very much, really appreciate it.

    Can you try the Parallel w/ 0 processes again, then once it's stuck, check Task Manager and see if you have the following 3 processes running 

    cx1920.exe

    fl1920.exe

    fluent.exe

    Also, let's make sure it's not stuck because of licensing issue. Please try the following command in CMD Prompt

    "C:\Program Files\ANSYS Inc\ANSYS Student\Shared Files\Licensing\winx64\ansysli_util" -checkout FLUENT_SOLVER

    what is the output and does this take longer than 30 seconds to show the output ?

    Thanks,

    Win

  • pizzazzlouspizzazzlous Member
    edited June 2019

    Hi Win, 

     

    Thank you for replying! 

     

    Today I remembered that I had not tried turning off my VPN. 

    That was it (unfortunately). Fluent loads properly when I turn off NordVpn (close the app, kill the background process). 

    Then, the following processes asked permission to connect: 

    fl_mpi1920.exe 

    mpid.exe 

     

    Also, Parallel w/ 0 was the only one that did actually load even before. 

     

    I'd be very grateful if you have any suggestions on how to have Fluent AND NordVpn running (or any other vpn). And if you don't, then I'm still grateful and I'll just come to terms with it. 

     

    Have a nice day!

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 2019

    Hi pizzazzlous ,

    Oh, sorry, I misread it. Now that makes sense. When you run with the 'true serial' mode (Parallel with 0 cores) , it usually does not trigger any local networking or Firewall or Anti-virus issue. Only when you use the 'parallel' , it could trigger those as it's now involving MPI and requiring much more local networking communications.

    Unfortunately, I can't say the exact fix for VPN as different VPN software could affect local networking in many different ways (built-in Firewall, change IP resolution, etc.) and for some VPN, it does not even allow you to control any of it. Your best bet may be to contact someone very experienced with networking from NordVpn and see if they have any suggestions. 

    You have a nice day too !

    Thanks,

    Win

  • pizzazzlouspizzazzlous Member
    edited June 2019

    Well, I'll keep looking into it. (And switch off my VPN when needed. Sigh, VPNs.) 

    Thank you very much for responding so quickly to the initial post and for the very specific suggestions. That's really good support! 

     

    Goodbye

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 2019
  • mohanpannirselvam08mohanpannirselvam08 HamburgMember
    edited January 12

    Hallo everyone, I am reposting this in this tread for more helping hand,

     

    I faced this same problem for past two weeks and finally solved it.

    My Fluent keep pointing the error " Fluent application failed to start".

    and in the Fluent log box says "Unable to connect to external socket: Error during socket creation Opening output fil".

    Based on this I assumed there is a connection failure between a Host and client.

    My set Up is a Client Side on Windows 10 with a VPN (Cisco) where i am receiving the license for Anysy from my university.

    I did everything as mentioned turning off firewall, reinstalling as admin, reconfiguring my VPn. but neither was working.

     

    Solution

    In the end , i traced back the problem to my Hyper-V Virtual Adapter Ethernet. If you are a Android Studio developer most probably you have this one too.

    Deactiavte it as i showed in this image. After that restart the pc and all error will not show again.

  • hadzovicthadzovict Member
    edited April 24

    Hi pizzazzlous,

    You did a great homework ! Thank you very much, really appreciate it.

    Can you try the Parallel w/ 0 processes again, then once it's stuck, check Task Manager and see if you have the following 3 processes running 

    cx1920.exe

    fl1920.exe

    fluent.exe

    Also, let's make sure it's not stuck because of licensing issue. Please try the following command in CMD Prompt

    "C:\Program Files\ANSYS Inc\ANSYS Student\Shared Files\Licensing\winx64\ansysli_util" -checkout FLUENT_SOLVER

    what is the output and does this take longer than 30 seconds to show the output ?

    Thanks,

    Win

    Hi Win, 

    I have the same problem. I started it in parallel with 0 and it gets stuck while in task manager I don't have the all three things that you mentioned. I also ran this command in Command Prompt and I get this:

    "E:\Program Files\ANSYS Inc\Shared Files\Licensing\winx64\ansysli_util" -checkout FLUENT_SOLVER

    FLUENT_SOLVER OUT id=license3_rz_RWTH-Aachen_DE-lmadmin-14897-248519 shared_info=license3_rz_RWTH-Aachen_DE-lmadmin-14897-248521 is_sharable=yes [email protected] is_academic=yes has_academic_logo=yes max_h_elem=512000 max_nodes=0 max_faces=0 max_bodies=0 max_species=0 min_cell_size=0 max_depth=0

            Resolved by Feature: id=185 feature=aa_t_a product=ANSYS Academic Teaching Mechanical and CFD

    Unfortunately I cannot turn off the VPN since it is needed to connect to the university license.

    Do you have some more suggestions what I can try in order to run Fluent properly?

    Thanks in advance,

    Tarik

     

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited April 25

    Hi Tarik,

    In Fluent Launcher, click more options -> parallel -> select MPI type to be MS-MPI and check the box to specify IP address to be 127.0.0.1. Now, launch Fluent.

    Does that help ?

    Thanks,

    Win

  • luckfanluckfan Member
    edited July 9

    Hi Win,

            In Fluent 15.0,There is no option to specify the IP address you mentioned!

     

    Thanks,

    Luck

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited July 9

    Hi Luck,

    Sorry. I forgot to emphasize. The trick that I mentioned above only works with Fluent 2019 R1 or newer versions.

    Can you install a more recent version ?

    Thanks,

    Win

  • Hi pizzazzlous,

    If you have antivirus then turn all its features Off. And run the fluent using admin keeping Windows firewall ON. If you are using any VPN, then switch off it also.

    Error - ** No cached password or password provided.use '-pass' or '-cache' to provide password **

    The similar problem I faced because I had installed an antivirus. I hope u could figure out this.

    Thanks,

    Chitransh

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Thank you for sharing your resolution Chitransh

    Win

  • OkameOkame Member
    edited September 4

    Hi

    Im posting on this thread because im having a similar issue where my Fluent (when launched from workbench R20) fails to start and sends an error message: "The Fluent application failed to start", after it loads for about 30 seconds. I have no idea what is causing this and what to do.

    Ilease can someone assist me in this matter urgently have tried the following:

    • Changing the Fluent launcher settings to MsMPI and IP address to 127.0.0.1
    • The launcher doesnt allow me to change the processes to 0 and remains at 1
    • I tried to check if it is a licensing problem in workbench but the license preferences contain the required AIM Student, Academic Teaching introductory and Discovery live student licenses. However Im unable to open the student.lic file using notepad for some reason
    • ive tried checking for possible interferences from my VPN(Cisco) however Ive already disabled it as mentioned abofter the error message pops up I am now unable to close the failed program and have to restart my laptop everytimev
  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Try setting the process to 1 in your Fluent Launcher and also setting the following Windows environment variable

    Name : RUN_WITHOUT_MPI

    Value : 1

  • Thanks I just tried it however it still does not work and I am still getting the same "The FLUENT application failed to start message" however, the FLUENT application now proceeds further and loads up the "Key behavioral Changes" message before the error message pops up and the fluent application jams again. So Im assuming some progress is being made.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    ok, I think you have 2 issues.

    The first was fixed with serial mode.

    For the second one, can you try opening a stand-alone Fluent and see if it works ?

    Do you have any dedicated graphics card on the machine ?

    Try updating graphics driver from its vendor website (do not use Windows Device Manager to update it)

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    You can also try adding the following

    FLUENT_LAUNCHER_OPTIONS=-driver msw

    in the Environment tab of Fluent Launcher.

    If that doesn't help either change from 'msw' to 'opengl' or 'opengl2'

  • Hi, is there anything else I can also try to fix this issue?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Did you try my suggestions above ?

    There were also a couple questions that need answer.

Sign In or Register to comment.