Ansys Mechanical APDL freezes by requesting any inforamtion from the Main Menu

Hi,

I started working with Ansys Classic just some days ago. It worked fine and I already created some basic models.

Since this morning the programm freezes every time I request any kind of information from the main menu.

For example, I just defined three element types and I wanted to check them under Preprocessor>Element Type> Add/Edit/Delet. As soon as I try to open that list the program freezes and I can only close it through the Task manager.

I also saw, that a "cleanup-ansys-PCName-No." batch file is created. I'm not sure if that's normal or not, but I haven't noticed those files before the problem occured.

I restarted the PC, I uninstalled Ansys and installed it again but it's still the same problem.

Maybe I have to mention that windows requested a reboot this morning for some updates. Maybe that could be a reason?

I would be very happy to get some help with this!!

(I downloaded the student version 2019 R2.)

Thanks in advance 

 

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited September 2019

    If it worked earlier and stopped working all of a sudden, first thing you can try is to reset ANSYS configuration (These don't get deleted even if you uninstall ANSYS)

    You can do this by renaming C:\Users\<your_username>\AppData\Roaming\Ansys   folder to something else or you can launch CMD Prompt and issue the following command

    move %appdata%\ansys %appdata%\ansys.old

    Thanks,

    Win

  • SilkeSilke Member
    edited September 2019

    Hello Win,

    thanks for your answer. I just used the command you suggested and it woked fine. 

    But unfortunately it could not fix the problem. Any other ideas?

    Thnaks,

    Silke

  • SilkeSilke Member
    edited September 2019

    I just found out that submitting the job via APDL Product Launcher works fine.

    So it must be a problem with the Mechanical APDL interface or something like that.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited September 2019

    I've not seen a graphics issue with M-APDL GUI (since the GUI itself is pretty old and should not require much) but just for a kick, let's check graphics. What graphics card do you have on the machine and can you update its graphic driver to the latest according to the vendor website ?

    Thanks,

    Win

  • wizard36wizard36 Member
    edited April 14

    This was happening to me too.  What I figured out was that I had moved from my desk with 3 monitors to my home office with 2.  When I had apdl open on the second monitor APDL was trying to open the pop-up boxes on a monitor that wasn't attached.  So it looked like it was frozen but in fact, it was just waiting for me to use the pop-up box that was open on a virtual monitor I couldn't see.  Once I moved the apdl to my laptop monitor it worked fine; opening the menu windows on the same monitor.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited April 15

    Thank you for sharing your resolution wizard36

  • Thank you wizard36. I scratched my head out trying to figure the problem. APDL worked fine once I disconnected the monitor. SMH it was this simple.

Sign In or Register to comment.