Interior is correct, and that is unlikely to be causing the problem. Whenever a model fails with UDFs the first step is to remove the UDF. Patch a temperature in and use a fixed time step. You also need to review the error in Fluent as that'll be more diagnostic. Once we know the mesh & solver settings are OK use the UDF patch function and run and finally reapply the time stepping method you've designed. For info, a UDF can return no errors as it's grammatically correct but still cause the solver to fail either through omission (data is missing) or by producing values that cause instability in the code.https://forum.ansys.com/discussion/comment/101937#Comment_101937

Hi Rob, nI completed the debugging tips that you mentioned and was able to identify what I believe to be the main cause of the issues with my simulation. nI had been using user-defined properties for the air within the domain. As such, I tried using the Fluent-defined properties of air and my simulation progressed as intended (i.e. including with the use my UDF for temperature initialization and time-step control). nHowever, in my user-defined properties of air, I set the air to be modelled as an incompressible-ideal-gas . So, for trial, I altered only the density of air given by Fluent-defined properties (i.e. constant) and set it to incompressible-ideal-gas. After this change (and with all other settings and properties the same from the simulation run that worked), the simulation failed. nTherefore, I think the primary issue with my simulation was modelling air as an incompressible-ideal-gas. nWould you happen to know why this might be? Or what adjustments can I consider make such that air can be modelled as an incompressible-ideal-gas as opposed to having a constant density?nThanks, nRyann