Thanks mmadore for your effort. Right now Workbench / Fluent is getting along with Ubuntu just fine for the past month.nThe solution was to set kernel.yama.ptrace_scope to 0, using the following command in terminal:necho 0 | sudo tee /proc/sys/kernel/yama/ptrace_scopenAnd then select openmpi in Fluent Launcher -> Parallel Settings -> MPI Types .nHope anyone having similar issues finds this helpful.nn