Yes, add Weak Springs. I assumed that was turned on when I watched your video, but then you scrolled down and showed it was off. It was a fluke that the simulation solved.
You might also need to change the Analysis Settings, turn on Auto Time Stepping and set the Initial Substeps to 100.
A different way to get this to solve is to split the body in half and put a symmetry boundary condition at the center.