Sahil Sura
Ansys Employee

You may try splitting edge in specific number of elements and then go for full body meshing. This will give you a better mesh control(More on this in the references (1)).Cyclic symmetry was a better option as non symmetrical results can also be obtained using the same. After updating the mesh, if the error still persists, you may add the screen capture/ error copy pasted here.
You might try axis-symmetry as seen from the above screen capture, the boundary conditions are symmetric about the Z axis. This will also give you a better mesh control.
You may even use planar symmetry to simulate the half model. It really depends up to the user convenience. Just make sure the symmetry normal and other options are aptly set.
For expansion of the results, You must check the details of the symmetry tab if visual expansion is available, if not , enable the "Beta Options". The following path will help you for the same-
Go to workbench project window ---> Tools ---> Options---> Appearance---> Check the Beta options check box.
On doing so, whenever you click on the symmetry option in Mechanical, in the Details you will get the options for visual expansion of results. Adding a minute displacement value for the respective axis (For planar), and adding the number of sectors for cyclic will expand the results accordingly more on the same from the references below (3)
Mesh ( Apply Mesh Controls and Preview Mesh (
Cyclic Region Overview ( General Axisymmetric Overview (
Reviewing Results for Cyclic Symmetry in a Static Structural or Static Acoustics Analysis (
Hope that helps!
Thanks Sahil