arcadianleericky
Subscriber
Hi Greg Thanks for helping.
I'm afraid our cluster is missing the proper graphics component/plugin to enable the GUI feature, because when I ran
/opt/lumerical/v212/bin/fdtd-solutions
The following error occurs: Aborted (core dumped) $FDTD_BIN_DIR/fdtd-solutions-app "$@".
See the image below for details of this error:
After searching online for how to fix this error, I found the following post on ALF, which encountered similar issues to mine:
https://forum.ansys.com/discussion/33383/lumerical-crashing-on-centos
The answers in this post suggested that it's a OpenGL problem, which is again related to graphics.
could you guys help me with this? I wanna know if it's impossible to run FDTD from the python API using lumapi without needing an OpenGL-enabled GUI. Currently, when i run my python code on the cluster to execute an FDTD simulation, I have the following error:
"LumApiError: 'appOpen error: \n Failed to start messaging, check licenses...'"
Which i think is related to the graphics issue discussed above.