Erik Kostson
Ansys Employee
As we said this is one of the main issues so go to both contacts and change :
so under the details of the contacts, change the settingContact shell facetoBottomon both contacts, as it is set to top now and which is not correct.

Finally in the contact settings set Interface treatment/Offset to adjust to touch:
https://www.padtinc.com/2020/06/04/a-simple-adjustment-to-fix-a-contact-convergence-problem-in-ansys-mechanical/
All the best