Guilin Sun
Ansys Employee

"autoshutoff level > 23 " indicates that the simulation is going to diverge. You may

1: modify the material fitting to make sure the fitted curve is smooth without suspecious spike; You will also need to use getfdtdindex to get the actual refractive index used in simulation in order to compare the result from Mie scattering calculator.

2: make sure the PML is away from the metal scatter, for example half wavelength

3: Usually finer mesh is used for the scatter. so you may need to simulate larger volume to make sure that thePMLs are located in uniform mesh region, with sufficient thickness (number of layers times the mesh size).

You may simply use mesh accuracy 2 with override region for the scatter, and do not use uniform mesh for the whole simulation. instead, use the default auto-non uniform mesh.

4: You can also use symmetry BCs if the scatter has symmetry: https://optics.ansys.com/hc/en-us/articles/360034382694-Symmetric-and-anti-symmetric-BCs-in-FDTD-and-MODE

5: once not diverging, you may need to do converging test: Convergence testing process for FDTD simulations – Ansys Optics  if you want to compare with analytical solution.

Please try, and paste some screencopies if it still diverges, for example the material fit, mesh, scatter, PML settings etc.