David Weed
Ansys Employee

Hi, Intel OneAPI Toolkit is not supported for UPF compiling/linking, rather see what is supported in the Installation Guide: https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v221/en/installation/win_compilers.html

Microsoft Visual Studio Professional 2019 Version 16.0.22 (including the MS C++ compiler), Intel C++ and Intel Visual FORTRAN 2019 Update 5 (2019.5.281). compilers

Given this, we can't guarantee that the compilation/linking process will perform correctly using OneAPI. I would say make sure that MS VS is installed first, then install OneAPI so that they can integrate correctly. Beyond that, we can't say what the issue could be since this software is not supported.