C N
Ansys Employee

hello 

In addition to that 

I recommend you to distinctly separate the fluid and the object under cell zones setting and create two zones. 

Then create a profile for the object and then for the fluid with appropriate requirements.

Then apply the dynamic meshing option in which set the stationary motion option type to  the object .

By default if no motion (moving or deforming) is assigned to boundary or cell zone, this zone is not considered during the mesh update. Then apply rigid body motion option to fluid about z axis orientation by loading that fluid profile.This may solve your problem and then the object will not rotate along with the fluid. You can also create a separate udf instead of creating profile. For further understanding please check on dynamic meshing tutorials from users guide. hope it may solve your problem.

thank you