Khashayar Ghaffari
Ansys Employee

Hi Eitan,

Thank you for the information. In this case, you may try disabling the mesh constraint; this might be helpful since you mention having enough resources for meshing could be the bottleneck which makes sense given high number of mesh cells.

Therefore, try disabling the mesh constraint, and then switching to advancing front. At the same time Increasing the values of max and min edge length (making the mesh coarser) could be helpful. I suggest testing different combinations of min and max, also in combination with different meshing methods (hybrid, advancing front, and vertex insertion). 

This is certainly a challenging structure to mesh so finding the right settings to resolve the mesh could be time consuming. 

All the best