Burak Kılıç


Here are the results. Firstly, I need to specify the build installed is v222 right now.

In my system32 folder, I have only “libiomp5md.dll” and “mkl_intel_thread.dll” between the ddls mentioned above. “mkl_intel_thread.dll” is from 2012 which is pretty old.

Renaming “libiomp5md.dll” didn’t affect anything.


On the other hand, renaming “mkl_intel_thread.dll” gives an error while meshing, at least something different happened.


There are two folders inside C:\Program Files\ANSYS Inc\v222\tp\IntelMKL

”2020.0.166″ and “2021.3.0”.


I copied “mkl_intel_thread.dll” from “2020.0.166\winx64\” to “system32” folder.

Well, that also gives the same error.


I also copied “mkl_intel_thread.1.dll” from “2021.3.0” to “system32” folder and renamed as usual “mkl_intel_thread.dll”

That also gives the same error.


TL;DR: In “system32” I put 2 different “mkl_intel_thread.dll” one by one


  1. From C:\Program Files\ANSYS Inc\v222\tp\IntelMKL\2020.0.166\winx64\ mkl_intel_thread.dll
  2. From C:\Program Files\ANSYS Inc\v222\tp\IntelMKL\2021.3.0\winx64\ mkl_intel_thread.1.dll


3rd option is the deleting all “mkl_intel_thread.dll”s from system32, which is also the same. 

Any other idea?

P.S.: When I back to first "mkl_intel_thread.dll" it gives the error in the beginning. So, it seems that this dll cause the problem.