Guilin Sun
Ansys Employee

To have accurate frequency domain result from time domain signal, the signal should be completely decay, which is roughly controled by the autoshutoff min (becuase it is computed in time domain). I believe you have used sufficently small autoshutoff min in this case, as there is no strong resonance. does the simulation terminate before 100%, say before 95%? if not, you will need to significantly increase the simulation time, for example 10 or 100 times more than the current value, and let the autoshutoff min to terminate the simulation.

The rriples can aslo be originated from PML: too close or not thick enough, or improper type. Please increase the distance between the PML and the device, usually half wavelength or so; increase the number of PML layers; and if there are higher diffraction orders with large angle, in particular over 80 deg, please use Steep Angle PML. 

If the mesh is very fine in front of PML, you may consider to use custom PML . If you do not know the PML parameters, you can copy them from the current PML, and only increase the max number of pml layers and use it. 

Please note that the publication used dense wavelength sampling. You can increase the number of frequencies later. However you can choose "use wavelength spacing" either for the specific monitor, or in the "global monitor" settings since the plot is with wavelength.

I hope those will be helpful. Please try.