Maybe this will help others. I did get the same error message but could just fix it by deactivating the usage of CFF-File-Format using the command line 

”file/cff-files? no”. See also: Fluent 2020R1 > Fluent User’s Guide > 3.3.4. Reading and Writing Files in the Legacy Format


Context: I had an old simulation with 40 time steps that was simulated using ANSYS Fluent 2020R1 and the results were saved as .cas.gz and .dat.gz . When I tried to extend the calculation for 40 more time steps in a newer Version or even in ANSYS Fluent 2020R1 Fluent tries to use the .cas.h5 and .dat.h5 formats. This can be suppressed with the command above for the present Session only or also for future Sessions via the preferences, see User’s Guide entry above. Now, the extended calculation saves every time step in the old/legacy format, without error messages.

This is also helpful, because I can now use CFD-Post to have it read all time steps and generate Animation sequences from it. The features that Fluent offers are not sufficient in my case.