sorena shahbazi



Hello David
Fortunately, the problem was solved and I wanted to give feedback about this incident
First of all, thank you for your attention and guidance
After trying different things, it finally occurred to me to remove the ans_user_path” in the system environment, and to my surprise, the problem was solved and the subroutine was read and run correctly! Of course, I don’t know exactly why! It seems that with this definition, there is a confusion between the directory folder.
I should mention that I use the ACT UPF extension v4… of course, the problem I have is that when I use command (/upf, subroutine_name.F) instead of the extension, I get an error and the problem does not run at all. I still haven’t figured out the root of this error, why it doesn’t run when I use command instead of the extension, even if *ans_user_path is defined in the system environment. It may be related to the correct address of the directory folder.

In this regard, I want to ask another question that when we install Ansys workbench, where exactly is the address of the directory folder by default that we put the subroutine in it and can run the problem without using the extension ond only use the command ? I tried different folders and unfortunately I didn’t get any results and they all gave errors (with Solver Module content).

Thanks so much

+In the meantime, I would like to mention that Ansys 19.0 was linked with Visual Studio 2015 Update 3 and Fortran 2017 Update 5, similar to 19.1 and 19.2, but different from what is announced on the official website for this version.