Devendra Badgujar
Forum Moderator


There is known issue which came up today with users who do not have English language for the browser. The team is working on fixing this soon. 

Until then I would suggest please switch to english settings for the time being in your browser and/or use a new incognito window. I will update you once this is fixed.