Amrita Pati
Ansys Employee

Hi,

Thanks for sharing more information! It could be a number of reasons, we can take a look at various things one by one to see if we can get better agreement. I don't think we have to have any separate considerations while comparing the FDTD and TMM results. If you trust the TMM results, we just have to make sure that the FDTD results are accurate. I will start with some simple suggestions, you can test them, and then if there is no improvement we can go into more details.

  1. Status of the simulation: There are some ripples (near the minima) which I don't think is expected. Ripples in most cases are indicative of the simulation not having reached the auto shutoff level. After you run the simulation, click on the FDTD object, in the Results View Tab (below the Objects Tree section), you should be able to see a result called "Status". After the run the status should be 2. If it is 1, that means the simulation hasn't had enough time to reach the auto shutoff. So, increase the simulation time (maybe around 10 times) and then rerun it see if there is any improvement in the ripples. If the status is already 2, reduce the auto shutoff level to 1e-07 from 1e-05 in the Advanced options tab of FDTD object and run again.
  2. Also, for FDTD are you using dispersive material or a fixed index? Make sure that this is consistent with what you are doing in TMM. And if you are using dispersive material, check the fit in FDTD, make sure that the values of indices used by the model are close to what has been used in TMM.

Let me know what happens after you make these changes. 

Regards,
Amrita