Federico Alzamora Previtali
Ansys Employee

You should have two zones on either side of the circle highlighted in blue in your 3rd screenshot. If you don't, you may have to "slit" the single face zone in Fluent. You can do this with the following TUI command: define/boundary-conditions/modify-zones/slit-face-zone [id or name of face zone, right now it seems like you called it "wall-inner"]. Do the same thing if "wall-inner" is a coupled wall/shadow.

Once you have 2 faces zones on either side of the blue line, make sure you have the 1 to 1 pairing enabled (this should be default). In the console, enter define/mesh-interfaces/one-to-one-pairing? yes

Then, to create the mesh interface, go to Domain > Interfaces > Mesh... select the two face zones making up the interface. If the regions on either side of this interface are both of type Fluid, the interface will be changed to type Interior automatically.