Xabierenko
Subscriber

I have also tried creating a macro on Fluent where my commands are saved. I end up with the following macro:


(cx-macro-define
'((MitralValve . "(cx-gui-do cx-activate-item "Execute Commands*PanelButtons*PushButton2(Cancel)")n/solve/execute-commands/add-edit a 41 "time-step" "define/boundary-conditions/zone-type wall) 5 pressure-outlet" n/solve/execute-commands/add-edit b 41 "time-step" "define/boundary-conditions/pressure-outlet mv yes no 1067 no yes yes no no no" n(cx-gui-do cx-activate-item "Calculation Activities*PushButton7(Create/Edit)")n")
))

So then when I save the macro in a macro.scm file I can load it and execute it from the TUI command prompt. If done directly from the fluent prompt it works perfectly:


/file/read-macro macros.scm
/file/execute-macro mitralvalve

However, once again when I do the exact same thing on MATLAB through the aas toolbox it fails. Any idea of why is this happening? Doesn't make any sense to me... I have tried everything.


iFluentTuiInterpreter.doMenuCommandToString('/file/read-macro macros.scm')
iFluentTuiInterpreter.doMenuCommandToString('/file/execute-macro mitralvalve')
ans =

Warning: An error or interrupt occurred while executing the macro.

Some commands may not have been completed.

Any help is welcomed, I am quite in a hurry at the moment.