Hi Glenn,

I recommend you idealize the geometry a bit before you try to mesh it.  For example, there is a 0.1 mm thick tab, is that feature important? Probably not. So trim it off. 

You can enable automatic Mesh defeaturing, which will take this out, but it is cleaner to do it manually.

I don't know TurboCAD, but the surfaces that make the 90 degree bend at the end are horrible and full of ripples. When you have the mesh set to Capture Curvature, as you did, it makes smaller elements just to capture these ripples, which I don't believe are there intentionally. 

When you turn off Capture Curvature, and enable Mesh Defeaturing, you get a valid mesh.

 ANSYS 2019 R2 archive attached.