Cheers Peter.  I will look into cleaning it up either manually or automatically and turn off the curvature thing (not sure that I knew that setting was on lol).

 I did notice that looking under Mesh in the Outline window there is a black cross against Patch Conforming Method.  Not sure if this means you did not use this?

Appreciate the help.