I would guess that the mesh element size and the contact detection settings are creating the hot spots shown in this image.

I expect with smaller elements and changes in the contact settings, you can smooth out those hot spots which must be artifacts and not the true solution.