Naresh Patre
Ansys Employee

Hello oni

The message related to pre-boundary layer generation is a warning message and not an error message. So if there are no other error messages, you should have the mesh generated for the model.

The message indicates that boundary layers failed to generate due to reasons mentioned in the message. To overcome this issue, go to Boundary Layer Settings in Mesh task. Select Collision avoidance option as "Layer Compression" and Maximum Angle as 180 deg. See below snapshot.


Additionally, if the geometry has any thin regions ensure that there are minimum 3 mesh elements in the gap. You can use mesh controls and specify appropriate sizes in such areas. Or you can also use "Curvature and proximity" sizing function under global sizing. Here you can specify the proximity min size as 1/3rd of the thin region.