Electronics

Electronics

ANSYS AIM Electromagnetics “DataContainer” Error

    • Les-O-Lee
      Subscriber

      error message


      Did you ever find out what the problem was? I am getting the same thing on AIM 18.2 Magnetics by just following the tutorial :-(


      I had installed AIM 19.0 and then reinstalled it twice for the same problem before "downgrading" to AIM 18.2. On the other hand at least the help works in AIM 18.2, which makes me feel that I have made some progress!


      My setup is Win 10 Home 64-bit with an AMD A10-7800 Radeon R7 processor.


       


      'DataContainerReference' object has no attribute 'GetGeneralPhysicsOptions'


      and


      Physics types: the selected physics type or combination of physics types is not valid.


      (There is only one selection: Electromagnetic.)


       



       

    • misge98
      Subscriber

      Hi, I am trying to use ANSYS AIM student 18 and 18.1 version to analysis electromagnetic force and torque but I am getting the error which is said 'DataContainerReference' object has no attribute 'GetGeneralPhysicsOptions'  for both version. Please, would you help me how can I solve this error? Thank you!  

    • pgl
      Ansys Employee

      Hi Les-o-Lee,


      We've fixed the help access for the R19.0 products - The product downloads we updated earlier this week, so feel free to upgrade to R19.0 again. I can understand the hassle, our apologies for that inconvenience.  


      On the "DatraContainerReference" error, take a look at this thread for some help. 


       

    • Les-O-Lee
      Subscriber

      pgl,


             I have posted details of the problem in this thread.


      https://studentcommunity.ansys.com/thread/magnetics-permanent-magnetic-circuit-with-air-gap/


      I have basically run out of things to try to get a workaround, so I might as well try the new 19.0 to see if it works there..

    • Les-O-Lee
      Subscriber

      Hi Les-o-Lee,


      We've fixed the help access for the R19.0 products - The product downloads we updated earlier this week, so feel free to upgrade to R19.0 again. I can understand the hassle, our apologies for that inconvenience.  


      On the "DatraContainerReference" error, take a look at this thread for some help. 



       The builddate.txt file in the unzipped downloaded folder says 12/18/2017, TC build number 179. The help still doesn't work. The SpaceClaim dimensioning still doesn't work properly, and the Electromagnetics of course still doesn't work.


      Also, this website doesn't include blockquotes and text in any understandable way!

Viewing 4 reply threads
  • You must be logged in to reply to this topic.