Ansys Products

Ansys Products

Ansys License Manager is up and running yet EnSight is still having a trouble finding a license file

    • cjhun
      Subscriber

      EnSight is having a trouble with finding a license file even though the Ansys License Manager is up and running.


      Briefly, we've been using CEI (Computational Engineering International) EnSight for CONVERGE Science CFD and everything was easy in terms of setting up a server and clients, and this is the first time for us to get a license from Ansys and nothing seems to be straightforward.


      Here's the step that we followed based on their instruction:


      1. Log on to the Customer Portal. 2. Go to Downloads / Current Releases / Choose v19.1 and my platform 3. Academic Packages > Fluids & Structures package 4. Downloaded FLUIDSTRUCTURES_191_WINX64.zip and  PREPPOST_191_WINX64.zip     Note: I don't understand why they instructed us to download everything under Fluids and Structures Package, but I simply followed the instruction anyway. 5. Unzipped both of them, and from the unzipped PREPPOST_191_WINX64 folder, ran setup.exe and installed only the Ansys License Manager (ALM).  6. Launched the ALM, and installed the key that they provided. 7. Launched the newly installed EnSight, and we keep getting the license error as shown in the screen capture below.   FYI: All is done on a server.      Thanks for your help in advance.   Unable to locate license  


       


       


       


       

    • tsiriaks
      Ansys Employee

      Hi cjhun,


      First, I would verify if ANSYS License Manager is up and running. You can check this by launching ANSYS License Management Center and see if the status says 'running' on all three components.


      If ANSYS License Manager is up and running, I would assume that the license file that has Ensight license is installed correctly as well. Then, you can check if the client (software, in this case Ensight) is correctly pointing to ANSYS License Manager by looking at this file (default path)


      Windows : C:Program FilesANSYS IncShared FilesLicensingansyslmd.ini


      Linux : /ansys_inc/shared_files/licensing/ansyslmd.ini


      make sure the content is pointing to the correct license server hostname, for example if the hostname is license1


      SERVER=1055@license1


      ANSYSLI_SERVERS=2325@license1


      Let me know if this helps.


      Thank you,


      Win

    • cjhun
      Subscriber

      Hi Win,


      Thanks for your help. I've reconfirmed that all three are at "running".


      Unfortunately, I don't see "ansyslmd.ini" from the Licensing folder (see the screen capture below). I do see a license file (ansyslmd.lic) in the license_files folder though, and I don't know how to make EnSight look at that folder as it doesn't pop up any options to choose as it used to. Please advise. Thanks again! Joseph


    • tsiriaks
      Ansys Employee

      Hi Joseph,


      Did you use the FLUIDSTRUCTURES_191_WINX64.zip to install Ensight software or it was installed by other package ? 


      If the Ensight was installed by either the package above or 'Fluids' package, you should have it under v191 folder (e.g., C:Program FilesANSYS Incv191CEI ) and this would use (and automatically create) the ansyslmd.ini on the relative directory to that v191 and should have the content like what I described.


      If the Ensight was installed by other package (e.g., Ensight products page or the legacy Ensight website) , it will install on the other location. In this case, you can try setting these environment variables


      ANSYSLMD_LICENSE_FILE=1055@hostname


      ENSIGHT10_LM=ansys


      Note: Replace hostname with the actual hostname of the license server.


      Thank you,


      Win

    • cjhun
      Subscriber

      Hi Win,


      Thanks again for your help.


      Yes, I downloaded the EnSight separately. Setting the environment variables worked somehow, but I've got new errors which I don't have a good idea. Is there anything else that I have to do with FlexLM while it's up and running? Thanks again.


      Joseph


    • tsiriaks
      Ansys Employee

      Hi Joseph,


      This means the ANSYS License Manager is up and running but is not really serving Ensight license.


      Run ANSYS License Management Center -> Display FlexNet License Status


      Check if you see a line that says


      Users of ensight......


      Or you can capture screenshot and post the entire thing here.


      Thank you,


      Win

    • cjhun
      Subscriber

      Hi Win,


      Please see the attached screen capture. In case of you not being able to read well from the image, it says:


       


      Last updated on 2018/08/30 08:45:06


       


      lmutil - Copyright (c) 1989-2015 Flexera Software LLC. All Rights Reserved.
      Flexible License Manager status on Thu 8/30/2018 08:45
      [Detecting lmgrd processes...]
      License server status: 1055@d9ryb8p1
      License file(s) on d9ryb8p1: C:Program FilesANSYS IncShared FilesLicensinglicense_filesansyslmd.lic:
      d9ryb8p1: license server UP (MASTER) v11.13.1
      Vendor daemon status (on d9ryb8p1):
      ansyslmd: UP v11.13.1
      Feature usage info:
      Users of ensight: (Total of 1 license issued; Total of 0 licenses in use)

       


       


      .

    • tsiriaks
      Ansys Employee

      Hi cjhun,


      Can you launch CMD Prompt, then issue the command


      set


      and post the screenshot of the output here


      Thank you,


      Win

    • cjhun
      Subscriber

      Hi Win,


      Good news! In the meantime, based on your hint, I've completely deleted the EnSight downloaded separately, and performed fresh installation from the unified package. It works great now! Thanks for all your wonderful support, Win! 


      All the best,


      Joseph


       

    • tsiriaks
      Ansys Employee

      Hi Joseph,


      That's great ! Thank you for letting us know.


      Yes, I think the installation package that you used must be from other package that is not Fluids or Fluidstructure package, which would install a different version of Ensight and that's why it doesn't see ANSYS license.


      Since the issue is resolved, could you mark this thread as solved so that others know that there is a resolution for this issue ?


      Thank you,


      Win

    • cjhun
      Subscriber

      Hi Win, 


      Absolutely! Please let me know whether I've correctly marked this thread as solved or not.


       


      All the best,


      Joseph

    • tsiriaks
      Ansys Employee

      Hi Joseph,


      Yes, you have marked it as solved correctly.


      Thank you very much.


      Win

Viewing 11 reply threads
  • You must be logged in to reply to this topic.