Electronics

Electronics

Ansys maxwell transient model motion error

    • okara
      Subscriber
      Hi. I have a error on transient model. I am getting the error The number of computational domain doesn't equal to one. %1 My project is about motion setup of permanent magnets. Do you help ? What can I do to fix this problem.n
    • icellb1
      Ansys Employee
      Hi,nYou can the following:nDo you have an outer Region that enclose everything? This is necessary.nDo you have multiple objects in the band but you did not assign and inner region to enclose the multiple objects?nIf there's only one object in the band, is it hollow or does it have holes? The object in band must be a single, solid object without any holes to break the domain.nIs your Region or band in hollow shape? They can not be hollow or have holes, either. If you have a outer rotor machine, you can rotate the inner stator instead as it's just relative motion, this way your band or region won't be hollow.n
    • okara
      Subscriber
      Thank you for your answer. I tried all you said but I am still getting the same error.nMy model as shown in the picture. I use two permanent magnets and iron core above the magnets. Steel plate in the band as you see in the picture. No holes, no hollow geometry as you see in the picture. Also vacuum object enclose everything. There is only one object in the band. Actually I tried multiple objects and one object in the band according to you said. None of all did not work.nn
    • icellb1
      Ansys Employee
      Hi,nBased on your description, your model looks fine. I built a model similar to yours and assigned similar materials as you described, but didn't get an error message. nn
    • okara
      Subscriber
      Did you send me the file ? my mail address is okaratar@gmail.com nthank you.n
Viewing 4 reply threads
  • You must be logged in to reply to this topic.