General Mechanical

General Mechanical

Ansys Mechanical crashing in random moments

Tagged: , ,

    • Maks Gepner
      Subscriber

      Hi!

      My Ansys Mechanical has been crashing regularly over the past two week or so. This has not been happening during the previous weeks of use of the software on the same hardware. I tried reinstalling the software and updating my graphics drivers but with no luck. I then tried the fix involving the deletion of 'v222' inside of the Ansys directory in %Appdata% -- this works, but the issue appears to reappear either after a couple of hours. I tried using a different file just in case the old one is corrupted, but with no luck.

      Any idea about what might be causing the issue? Please let me know what details would help, I am using Windows 11. The issue occurs in random moments when navigating the UI rather than when running the simulation -- I've actually never had it crash in the case of the latter. No error message appears, Workbench also does not appear to be affected.

    • George Karnos
      Ansys Employee

      If it just started happening, I would check changes/updates to the System. Any updates to the Operatng System?
      Virus scanner?
      Check the Windows Event Viewer for any errors when the crash happens.

    • Maks Gepner
      Subscriber

      Thanks for the reply. Is there anything, in particular, that you have in mind? Windows system updates happen all the time, so it would be quite difficult to pinpoint. I'm using the most up-to-date drivers for my hardware and considering the issue has been going on for 1-2 months now, it is possible that new updates came in in the meantime.

      Same thing with regard to the other points. I've checked the Windows defender/firewall settings and it appears that it should not be interfering with the software.

      I've never used Windows Event Viewer before, what should I look for here? There are no events or logs that from what I see that relate to Ansys, as far as the naming is concerned at least.

    • George Karnos
      Ansys Employee

       

      Updates would be a little difficult to narrow down, but ws looking for any update that
      was installed when the crashes started happening.

      I would try disabling virus scanning and test to see if that helps.

      As for the Event Viewer, Open the Windows logs and check Application and System for errors:

       

       

    • Robert Wagner
      Subscriber

      Hey there,

      I am facing the very same issue, similar timespan aswell. I assume correlation to the installation of a different ANSYS software (student version 22R2 to normal version 22R1). 

      I can reproduce the crash by clicking on Contacts in the UI.

      After checking my Event Viewer I get the following error:

      Faulting application name: AnsysWBU.exe, version: 22.2021.334.1, time stamp: 0x61a66590
      Faulting module name: ntdll.dll, version: 10.0.22000.918, time stamp: 0x57b668f2
      Exception code: 0xc0000374
      Fault offset: 0x000000000010c509
      Faulting process ID: 0x3e74
      Faulting application start time: 0x01d904cf343ae647
      Faulting application path: D:\01_Programs\01_CAD+Simulations\Ansys\ANSYS Inc\v221\aisol\bin\winx64\AnsysWBU.exe
      Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
      Report ID: 188116ce-65c2-4c59-b409-2e836233090b
      Faulting package full name: 
      Faulting package-relative application ID: 

      I couldnt find any helpful entries in the forum on the error code "0xc0000374".

       

      Thank you for your help.

      Kind regards.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.