Fluids

Fluids

Ansys Meshing Sweep Method Failure

    • SickOfAnsys
      Subscriber

      I am trying to use Ansys Meshing tool to create a sweep mesh, but I keep getting 5 errors:

      1. A mesh could not be generated using the current meshing options and settings.
      2. One or more bodies cannot be swept because a side face cannot be automatically map meshed.
      3. Sweeping failed because one or more side faces can not be automatically map meshed.
      4. Quad map meshing failed on one or more surfaces. A surface could be narrow with many boundary edges which may not have been properly paired up for meshing. Using hard size controls on the boundary edges to force the same number of divisions might help.
      5. An error occurred during sweeping meshing a face. Changing element sizing parameters might help.

      Right clicking the Mesh option in the tree on the left to select "show sweepable faces", I get the following which shows that my geometry is appropriate for sweep meshing:

    • Rob
      Ansys Employee
      How many volumes have you got? The top image looks to be a fluid zone, but the lower looks like a metal casing? What other mesh controls have you set?
    • SickOfAnsys
      Subscriber
      Hi Rob I think only the one volume; It's 1 part, 1 body and exported to the meshing program (is there a way to check number of volumes; on searching, Mechanical seems to have the function VSEL to select individual volumes).
      I am not sure why it looks like a metal casing following the failed mesh.
      I set edge sizings only for the other meshing controls, but have suppressed them now. This is what the mesh looks like with only sweep method, and element size 0.5mm:

      What I am trying to do with the edge sizing at either end is to split the mesh into smaller cells down the channel. I get the same errors listed above if I make the element size 0.1mm
    • Rob
      Ansys Employee
      Part of the problem is the source face thinks it's a topologically a square so rather than pave the face it's trying to give you a map mesh. On the source face insert a face mesh type and set Map to No.
    • SickOfAnsys
      Subscriber
      Hi Rob. Thank you for the suggestion. I've added a Face Meshing constraint (Mapped Mesh - No and Suppressed mesh - No) at the inlet side and I get the following:
      I then applied the face meshing to the outlet and walls that are not shown in the above image, and get the following:

      I'm trying multizone method and edge sizing on all edges selected at once; this produces a nice mesh but it takes a lot to generate - minutes at a time to update for each mesh density. Not that many elements, but multiples of millions of nodes:

      Issue with this method is I do not seem to have much control over the inflation near the contractions. Also, when cutting a plane it can be seen that the multizone mesh cuts diagonally (explains the huge number of nodes):


    • Rob
      Ansys Employee
      On the cut plane tool there's a pale blue triangle/tet shape. Click that as I think you're displaying the "half-cell" which always looks weird. If you're meshing for CFD alter the preferences, you need more smoothing for CFD.
      For the inflation, it's attached to the edges of the source face. You also need a small enough minimum size to get some cells between the opposing inflation layers.
    • SickOfAnsys
      Subscriber
      Cheers for the tip for not splitting cells when creating section planes.
      The sweep method only works for me when I set the Src/Trg Selection to "Automatic". However, when the mesh is created the central cells become too coarse:
      Setting the Src/Trc Selection to "Manual Source and Target", I get the same six (vague) errors as mentioned above.
      The Multizone method (after changing the Physics preference to CFD), I get the following:
      The barrier of this software is that I cannot easily modify the mesh density. ICEM is outdated, and tricky to use but at least from the outset it puts all of the control in the hands of the user (just care needs to be taken as any errors are hidden and unforgiven). This meshing software (for Ansys 18.1), is unusable and is just a barrier to my work. Unfortunately my IT department is as equally opaque and difficult so I am still awaiting my new machine so that I can use a more up to date software.
    • Rob
      Ansys Employee
      That'll be the max size and growth rate. Drop the default growth to 1.1 and review the size settings. You'll see some improvements into 2022R1 in Ansys Meshing, but also the addition of Fluent Meshing workflows: they give an unstructured mesh but that's fine for most things.
Viewing 7 reply threads
  • You must be logged in to reply to this topic.