Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

Ansys simulation using Fluent on Z820 Workstation

    • Losiola

      Hello ,

      I am new to ansys and i dont have that much of informations about it so hope that you can help me with this topic .


      i am making a 2D airfoil simulation using Ansys Fluent on my own laptop  i7 (4 cores -8 threds)  i ve run the simulation on fluent specifiying parallel with 6 process .

      later my professor provided me with a Z820 workstation with the same version of ansys but with 2 CPU (24 cores-48threads) , i was super excited and i wanted to know how fast it gonna go .. so i run the same simulation on the workstation in paralle specifying 36 processes  but i was schocked when i found that the worstation in only 2 faster than my Old laptop !!!!

      1/-Do you have any idea about what might be the problem ?

      2/-Does this has any relation with HPC license !!


      I appreciate any help that you can provide.


      Kind regards

    • Rob
      Ansys Employee

      Parallel does scale well, but as you put more cores in you also have to "pay" for data transfer between cores/nodes. Eventually the data transfer out weighs the speed boost for using more cores. For many Fluent models we're good down to 10-50k cells per core but it's also model dependent. Don't use hyperthreading either: it's not designed for CFD models. 

    • Losiola

      Ok ,

      i guess than that the problem is with the hyper threading ,Do you suggest that i disable it from BIOS ?or just keep it and instead of using logical  cores keep the number of processors  24 Cores ?

    • peteroznewman

      Yes, disabling hyper threading is recommended by ANSYS. You will be limited to 24 cores, but 23 cores might end up being faster.

    • Losiola

      Thank you very much for the assistance  i ve disabled hyperthreading and used 20/24 cores and the improvment is amazing .

      Thank you all

Viewing 4 reply threads
  • You must be logged in to reply to this topic.