General Mechanical

General Mechanical

APDL Stress/Strain Export Commands in Workbench Mechanical Data is not Available

    • PSchwarzenberg
      Subscriber

      My APDL Stress/Strain export commands in Workbench Mechanical are not working. A command such as: "ETABLE,Exx,EPEL,X", generates the error message of: "The Requested EPEL data is not available. The ETABLE command is ignored". Similar results are seen when attempting to export nodal data as well. 


      These exact commands worked previously on the same version of ANSYS (17.2). I have also tried ANSYS 18.2 and 19.2 resulting in the same error. However, if I open a Workbench project that was saved before April 2019, the commands work as expected.


       


      Thanks for the help,


      Peter

    • Sandeep Medikonda
      Ansys Employee

      ETABLE is just filling a table with element values of interest. There might be a problem with your selection logic preceding this or the quantity you are requesting might not exist for the material model you have? Please provide more details...Also what version does it actually work in?

    • PSchwarzenberg
      Subscriber

      In the past the code has worked with the ETABLE command as the first line of the command script. However, even adding an "ESEL, ALL" command gives the same errors. I have attached the previously working code at the bottom of this post, but the error is thrown in the first line and the following math operations are ignored because there is no data. Finally, an error is thrown when a variable is called to write to the text file and the command is terminated.


       


      The code works in 17.2 as long as the workbench file hasn't been saved since March 2019. The same workbench file will stop working if it is saved to the current date. 


       


      Previously working code:'


      ETABLE,Exx,EPEL,X !Assign elastic strain x to Exx

      ETABLE,Eyy,EPEL,Y !Assign elastic strain y to Eyy

      ETABLE,Ezz,EPEL,Z !Assign elastic strain z to Ezz

      ETABLE,Exy,EPEL,XY !Assign elastic strain xy to Exy

      ETABLE,Eyz,EPEL,YZ !Assign elastic strain yz to Eyz

      ETABLE,Exz,EPEL,XZ !Assign elastic strain xz to Exz




      !Calculations for Hydrostatic Strain

      SADD,EHXY,Exx,Eyy !Add Exx and Eyy

      SADD,EHXYZ,EHXY,Ezz !Add Exx, Eyy, and Ezz

      SMULT,E_Hyd,EHXYZ,,1/3 !Multiply result by 1/3







      !Calculations for Octahedral Shear Strain

      SADD,E1,Exx,Eyy,1,-1 !E1 = Exx - Eyy

      SEXP,E1SQR,E1,,2 !E1SQR = E1^2




      SADD,E2,Eyy,Ezz,1,-1 !E2 = Eyy = Ezz

      SEXP,E2SQR,E2,,2 !E2SQR = E2^2




      SADD,E3,Ezz,Exx,1,-1 !E3 = Ezz - Exx

      SEXP,E3SQR,E3,,2 !E3SQR = E3^2




      SADD,E12,E1SQR,E2SQR !E12 = E1SQR + E2SQR

      SADD,E123,E12,E3SQR !E123 = E12 + E3SQR




      SEXP,E4,Exy,,2 !E4 = Exy^2

      SEXP,E5,Eyz,,2 !E5 = Eyz^2

      SEXP,E6,Exz,,2 !E6 = Exz^2




      SADD,ESH12,E4,E5 !ESH12 = E4 + E5

      SADD,ESH13,ESH12,E6 !ESH13 = ESH12 + E6

      SMULT,ESHT,ESH13,,6 !ESHT = 6*ESH13




      SADD,ETOT,E123,ESHT !ETOT = E123 + ESHT

      SEXP,ETOTT,ETOT,,1/2 !ETOTT = ETOT^(1/3)




      SMULT,E_OSS,ETOTT,,2/3 !E_OSS = (2/3)*ETOTT




      *GET,ecount,ELEM,,COUNT

      *DIM,EARRAY,,ecount,2

      *VGET,EARRAY(1,1),ELEM,,ETAB,E_Hyd

      *VGET,EARRAY(1,2),ELEM,,ETAB,E_OSS

      *CFOPEN,Results,txt

      *VWRITE,SEQU,EARRAY(1,1),EARRAY(1,2)

      (F10.0,5X,F10.8,5X,F10.8)

      *CFCLOSE

       

    • Sandeep Medikonda
      Ansys Employee

      Can you issue the SET,LAST command first before executing the remaining post-processing commands in /POST1?

    • PSchwarzenberg
      Subscriber

      That did it! Everything is working as expected and as it did previously. Thank you for your help!

    • HeMeng
      Subscriber
      ArrayHello, SandeepMedikondanI have the same proble the error message of: The Requested SENE data is not available. The ETABLE command is ignored. nI solved the problem based on your suggestion, but I don't know why? Why add  the SET,LAST command ? Because I didn't add  the SET,LAST command in 16.0-18.2, it can run perfectly. But in 19.0-2020r12020r2 and 2021r1,  the SET,LAST command  must be added to run.nMy command is as follows;n/post1               nset,last                netable,den,sene    n     n
Viewing 5 reply threads
  • You must be logged in to reply to this topic.