General Mechanical

General Mechanical

Autodyn parallel processing

    • RashadUBC
      Subscriber
      Hi there Every time I create an automatic parallel process for my Autodyn model and hit run, I receive an error message. However, I installed all the product features.
      Any one know have to solve this problem?
    • peteroznewman
      Subscriber

      Please reply with a screen snapshot of the error message.

    • RashadUBC
      Subscriber

    • peteroznewman
      Subscriber

      I run Explicit Dyanamics from Workbench so I don't know how to run Autodyn from the native interface.


      Maybe someone else can help you with this error message.


    • Sandeep Medikonda
      Ansys Employee

      Rashad,


      If you are looking to run AUTODYN on the HPC, please see the instructions listed in the help here.


      How to access the ANSYS Online Help


      Regards,
      Sandeep

    • RashadUBC
      Subscriber

      Thank you for your concern

    • RashadUBC
      Subscriber

      Hi Sandeep,


      Could you please send me a pdf of these procedures as I can't access this link?

    • Venkatesan J.
      Subscriber

      Hi


      Make a .bat file with following content


      D:


      cd D:Program FilesANSYS Incv172aisolAUTODYNwinx64


      AUTODYNWRAPPER.exe -noinput -s 10


       


       


      Here, "D:Program FilesANSYS Incv172aisolAUTODYNwinx64" - is installation directory of autodyn (replace this with your installation directory)


      I have given the above content for 10 cores..... if you want to increase, change the number 10


      then just execute the bat file.... you have a autodyn GUI with parallel processing


      Cheer

    • RashadUBC
      Subscriber

      Thank you for your comment. I created .bat file and paste it in the folder (D:Program FilesANSYS Incv172aisolAUTODYNwinx64) then click it. After that I have tried to run my model but it still give me the same message. May be I missunderstood your procedures. Please, advise.

    • RashadUBC
      Subscriber

       Thank you so much for your reply. I created a .bat file  containing (


      D:


      cd D:Program FilesANSYS Incv191aisolAUTODYNwinx64


      AUTODYNWRAPPER.exe -noinput -s 6). I named it Aut.bat then I put it in the folder (C:Program FilesANSYS Incv172aisolAUTODYNwinx64) then click it. After that I have tried to run my parallel model but it gives me the same message. May be I missunderstood your above procedures. please, advise.

    • RashadUBC
      Subscriber

      thank you for your information, Sandeep


      Could you please send me a pdf of these procedures as I can't access this link?

    • niran24
      Subscriber

      before continuing check MPI is installed or not


      Method 1:



      • keep ready with your model, allocation the subdomin to particular cores, save and close the AutoDyn

      • open cmd

      • enter cd C:Program FilesANSYS Incv193aisolAUTODYNwinx64 ( go to this directory, version and installation disk may varies )

      • enter   AUTODYNWRAPPER.exe -noinput -machines "xxxxx:16" (xxxxx = your system name, you can find it in 'My computer> system properties' or Control PanelSystem and SecuritySystem,  16= n.o of cores - give same as n.o of task you allocated in the model)

      • above commands will launch AutoDyn go to file>open the xxx_0.ad file now click run

      • if you edit some thing after launching AutoDyn from cmd or stopped in between you have to repeat the same steps from beginning

      • you can check the performance of each core in View>Performance Profile, before that you have to create a empty text file in working directory where xx_0.ad file is available, name it as profile.cfg, before executing RUN open the Performance profile where you can find the performance of slave processor with respect to 1, make the all slave processor close to 1 for optimum utilization of hardware.


       


      Method 2 - you can find more about in help section 3.1.2. Running Autodyn with Intel MPI



      • create applfile and autodyn_mpi.bat as per 3.1.2

      • save those file in winx64 same path as above

      • enter cd C:Program FilesANSYS Incv193aisolAUTODYNwinx64 

      • enter autodyn_mpi.bat

      • above commands will launch AutoDyn

      • remaining and all same as above method


      Create a file called applfile, and in this file enter the following text, making the relevant changes for your parallel model, machine names, and installation path, should the installation not be in the default location:


      -localroot -env ANSYS_EXD_MPI_TYPE intelmpi -host [machinenameA] -np 1 –wdir "C:Program FilesANSYS Incv170aisolAUTODYNwinx64” autodyn.exe
      -host [machinenameB] -env ANSYS_EXD_MPI_TYPE intelmpi -np [number of slaves] "C:Program FilesANSYS Incv170aisolAUTODYNwinx64adslave.exe"

      create a blank file called autodyn_mpi.bat. In this file enter:


       


      set I_MPI_ROOT=%AWP_ROOT170%commonfilesMPIIntel4.1.3winx64
      "%I_MPI_ROOT%binmpiexec.exe" -configfile applfile

      Once the batch file is executed, Autodyn starts, along with the number of slaves specified in applfile. You can now create your model or load an existing one and proceed with your analysis.

Viewing 11 reply threads
  • You must be logged in to reply to this topic.