Fluids

Fluids

Axisymmetric Mesh: Warning about nodes below x-axis

    • conni
      Subscriber

      Hello everyone,


       


      I am working with an axisymmetric mesh in Fluent created in Workbench Meshing. I built the mesh by using the x-axis as axis and only working in the positive xy-plane. When importing the mesh in Fluent, it correctly assigns the named selections (inlet,outet,wall,axis). When performing a mesh check it fails with a warning saying:


      Checking for nodes that lie below the x-axis.


      WARNING: Invalid axisymmetric mesh with nodes lying below the x-axis.


      Checking element type consistency.


       


      I checked in the Meshing tool, there is nothing below the x-axis. Also, at the beginning of the mesh check, Fluent says:


       


      Domain Extents:


      x-coordinate: min (m) = 0.000000e+00, max (m) = 4.807069e-01


      y-coordinate: min (m) = 0.000000e+00, max (m) = 1.875000e-02


       


      Therefore, I do not understand how a node can be below the x axis if the same check that produces this warning says the domain only extends to xmin = 0.0


       


      When I use the TUI command "repair mesh" and check the mesh again, it does not produce this warning. However, I want to understnd how this issue is caused, so I can avoid it without using the repair-mesh function of which I am unsure how it works "in the background".


       


      Any advice is greatly appreciated.


      Thanks!


       


      best,


      conni

    • DrAmine
      Ansys Employee

      One can think that Fluent corrected everything in background but I cannot tell you now what is going on. Please export the mesh and read it in Fluent Standalone outside of the Workbench and check if you get the same issues.

    • conni
      Subscriber

      Thank you for the quick reply abenhadj,


       


      as a matter of fact I am running my simulations in standalone Fluent. I only use the Workbench for creating the geometry and mesh. I then export the Mesh as .msh file and import it to the standalone Fluent. Then, the error occurs.

    • Rob
      Ansys Employee

      In Fluent look in Translate (Domain tab I think). It's probably a rounding error from Meshing and your minimum y value will be -1e-12m or similar.  Which version are you using as tolerancing was fixed ages ago. You can then use the Transform option to shift the model slightly "up" so that y>=0

    • conni
      Subscriber

      Thanks for the suggestion rwoolhou !


      I will try it out later and mark the answer as solution if it works. I am using Fluent 2019R3 ,so a pretty up-to-date release i believe.

    • conni
      Subscriber

      Thanks for the solution rwoolhou,


       


      when clicking on "Transform" --> "Translate" it shows that the domain actually extends to something like negative E-17. I translated the domain into positive y direction by 1.0E-16 and it made the mesh check work (same result as when using "repair mesh").


       

Viewing 5 reply threads
  • You must be logged in to reply to this topic.