General Mechanical

General Mechanical

Can run harmonic with 4 parameters in 4 cores, but with 5 parameters only can in 1 core

    • fruswrit


      I have to perform 160 harmonic simulations with varying Young modulus, Poisson, density, stiffness and mass coefficients. To do that, I have an script that reads from a text file and assign to parameters. Then I run Ansys with the script from a Batch script loop. I use interactive mode while calling Ansys, to maximize compatibility and reduce potential errors.

      With those scripts I succesfully ran a previous test of 16 simulations with all the parameters but the density (4 parameters). After adding the density, however, I get the "An unknown error occurred" message. After checking the log, there is no error.

      File.err reads:

      /COM,ANSYS RELEASE 2021 R1      BUILD 21.1   UP20201109    08:50:39

       *** WARNING ***             CP =    2.359  TIME= 08:50:52

       Element shape checking is currently inactive. Issue SHPP,ON or     

       SHPP,WARN to reactivate, if desired.                   

       *** WARNING ***             CP =    2.812  TIME= 08:50:52

       Material number 3 (used by element 72853) should normally have at least 

       one MP or one TB type command associated with it. Output of energy by  

       material may not be available.     


      The log just stops at:

       Range of element maximum matrix coefficients in global coordinates

       Maximum = 5.42640519E+10 at element 5946.                              

       Minimum = 6611959.72 at element 73145.                                 



             1    21528 SOLID187    11.094  0.000515

             2    36828 SOLID187    17.922  0.000487

             3      757 SURF154      0.422  0.000557

             4        3 CLOAD201     0.000  0.000000

             7        3 CLOAD201     0.000  0.000000

       Time at end of element matrix formulation CP = 13.4375.                

       *** NOTE ***                           CP =     15.828  TIME= 08:50:57

       The initial memory allocation (-m) has been exceeded.                  

       Supplemental memory allocations are being used.   

      I have been monitoring RAM usage, with like 30 GB used. But I have 64 GB RAM, and no other process open. Task manager says I have like 14 GB free.

      There has been no antimalware updates that I know of in my computer.

      If I run the case without the distributed box checked it also crashes. If I run it with 2 processors, it also crashes. However, If I run it only with 1 processor it does go through.

      However, it would be quite faster to do the simulations with the 4 cores.

      Any clues? Thank you in advance!

    • Ashish Khemka
      Ansys Employee

      Did this happen only once? In case you start a new session and run the script with density then do you see a similar error message? Please let us know.

      Regards Ashish Khemka

    • fruswrit
      No, it is not dependent on whether I open it from scratch or not. It will consistently happen if it fails. No error, and no differences in the Solution Output.
      However, I think I fixed it (kind of) by changing 4 things at the same time: setting Variational Technology to No, Contact Split to Off, writing DB to On and (perhaps more importantly?) getting it not to erase unnecesary files.
      It is kind of buggy, and I have absolutely no clue why it is working sometimes and not others, but I will try with this setup and check if it runs.
    • Ashish Khemka
      Ansys Employee
      Thanks for the update. Please let us know how it goes at your end.

      Regards Ashish Khemka
    • fruswrit
      Just to bring some closure for others potentially experiencing this, I changed one other thing: I was running the simulation in a shared net partition, I changed that to the internal memory storage of my working station.
      I am 35 simulations in and everything works as it should, so I think case closed on my end.
      Thanks for everything
Viewing 4 reply threads
  • You must be logged in to reply to this topic.