Ansys Products

Ansys Products

Cannot solve [Error: Out of scheme heap space] ANSYS FLUENT 2019 R3

    • JD_JN
      Subscriber

      Hello everyone!

      I am running a 2d transient axisymmetric simulation on ANSYS FLUENT 2019 R3 owned by my college (Intel Xeon E5-1650 Quadro K620 Windows 8.1 Pro).

      The calculations were going on well, until recently it encountered this error of 'out of scheme heap space'. I tried running case and data files of previous flow times and they all run well - up to the point when it reaches a flow time of 9.26 milli-seconds post which FLUENT stops and throws out this error.

      I tried the solutions shown in the posts: https://forum.ansys.com/discussion/10380/error-out-of-scheme-heap-space? and https://forum.ansys.com/discussion/comment/17613#Comment_17613 but they do not help.

      I even tried to launch FLUENT via command terminal as suggested in : https://forum.ansys.com/discussion/comment/17613#Comment_17613 , but when providing an additional 'h' parameter in the launch command (fluent 2ddp -t6 -h50000) FLUENT gets called but does not launch. If the 'h' parameter is removed from the command line then it launches FLUENT - which does not serve the required purpose.

      The error log image is provided below:

    • Rob
      Ansys Employee
      Please add the image into the post, staff are not permitted to open or download attachments. n
    • JD_JN
      Subscriber
      Sure! nHere is the image of the error log.n
    • Rob
      Ansys Employee
      Try the command with -500000 as I think you've missed a 0 in the -h command:nnfluent 2ddp -t6 -h500000n
    • JD_JN
      Subscriber
      ! Thanks a lot for the response. I tried adding an extra zero at the end, but unfortunately FLUENT still does not launch.n
    • JD_JN
      Subscriber
      Right. nSo after few days of trying to find a solution, I got it!! The solution to this error for me was by deleting the solution export. (oh the irony! )nI had enabled automatic solution export in FLUENT. Weird as this may seem, once I deleted the automatic solution export, the calculations have begun to run smoothly again!nI tried to create a new solution export with a different name, but it throws an error each time it writes the solution after 1 or 2 time steps. I have no idea why though.nFor now, the way forward is by deleting the automatic solution export. If someone figures out why this happens, please do let me know.n
    • Rob
      Ansys Employee
      Odd, I moved it here as it may be installation related and knows all about that. What time step are you up to? I'm wondering if you've hit a limit somewhere in the code for the number format. n
    • JD_JN
      Subscriber
      Array I've set a time step size of 1E-6. The flow time is in milli seconds, and FLUENT would throw an error when exporting the solution once it reached 9.26 milli seconds. nI haven't the faintest idea as to why it does that. So once I removed automatic solution export, it stopped complaining!nCome to think of it, I had also enabled append flow time with the solution export file name. Is that what was causing the issue?n
    • Rob
      Ansys Employee
      Possibly, depending on the format you could be running out of numbers (figures) at that point. I tend to use %t (time step) when saving data & images, more as a habit than anything else as %t has been an option since at least Fluent 5.n
    • JD_JN
      Subscriber
      Well in that case, why doesn't it throw an error when auto saving case and data files?n I've set that on automatic too, and it appends the data files with the latest flow time but doesn't throw an error while auto saving and writing it. ?n
    • Rob
      Ansys Employee
      Good point. I'll talk to a developer. n
    • JD_JN
      Subscriber
      Awesome! Much appreciatedn
Viewing 11 reply threads
  • You must be logged in to reply to this topic.