Ansys Products

Ansys Products

Cant pull network license over VPN in 2019R1, but 2018 works fine (win7)

    • JustMason
      Subscriber

      Hello all, glad to be here.


      I am a Computer Manager at an institution, and as such responsibility falls on me to keep professors connected and happy...


      Anywho, I have a professor running win7 on an older laptop, and upon installation, we have found his (fresh) install of ANSYS 2019R1 unable to pull a network license over Cisco VPN. The strange part is, a 2018 build of ANSYS is perfectly capable of doing so under the same conditions.


      Both work fine when on-site, as well.


       


      When starting 2019R1 Mechanical APDL, there is an extended hangtime (up to a minute in some cases) before the applications states it is unable to pull a license.


       


      I have:
         Ensured telnet/pingability of client pc to the license server,


         checked/added firewall exceptions,


         removed any installations older than 2018,  and


         fully reinstalled 2019R1 to no avail.


       


      Has anybody encountered a similar issue?


       


      While I understand win7 is deprecated, any direction is greatly appreciated.


       


      Regards,


       


      -Mason


         

    • George Karnos
      Ansys Employee

      Hi Mason,


      What version License Manager are you running on the License Server?


      It may be one of two things:


      1. License Manager is older allowing 2018 to run. (Updating the ANSYS License Manager software on the License Server should fix this)


      2. The license file you are using is not current in TECS. (Meaning it will not allow newer programs to run)


      You can check the following for License debug information that may point to the issue:


      The directory:    %TEMP%.ansys


      Will have licdebug files in it.


      Check these files for any errors.


      Please let me know if this helps!


      Best,


      Geo


       


       

    • JustMason
      Subscriber

      Hello Geo,


       


      My server is running the 2019 R1 License Manager, which seems to function fine for all the lab computers running 2019 R1. I will have the professor bring his laptop in so I can comb through the license debug information. I'll keep you posted.


       


      Regards,


       


      -Mason

    • JustMason
      Subscriber

      Apologies for the delayed response,


      The "licdebug.ANS_INFO.193" file seems to be the most informative:



      2019/08/12 12:19:50    NEW_CONNECTION     


                                      Connected to license server: 2325@server.edu.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/12 14:449    CONNECT_ERROR                                                                                            0/0/0/0   2344:ANS_INFO:Mike@Mike-HP:winx64                          0:192.168.1.112    


                                      Could not connect to license server: 2325@server.edu. Connection timed out while connecting to the server.


      2019/08/12 14:449    CONNECT_ERROR                                                                                            0/0/0/0   2344:ANS_INFO:Mike@Mike-HP:winx64                          0:192.168.1.112    


                                      Could not connect to any license server.


                                      The server is down or is not responsive.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/12 14:47:08    NEW_CONNECTION     


                                      Connected to license server: 2325@server.edu.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/13 192:09    HEARTBEAT                                                                                                0/0/0/0   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


                                      System error: 10054 "An existing connection was forcibly closed by the remote host.


       


                                      ".


      2019/08/13 192:10    SERVER_DISCONNECT                                                                                        0/0/0/0   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


                                      License server 2325@server.edu has disconnected unexpectedly.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/13 193:28    CONNECT_ERROR                                                                                        0/0/76763/0   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


                                      Could not connect to license server: 2325@server.edu. Connection timed out while connecting to the server.


      2019/08/13 193:28    CONNECT_ERROR                                                                                            0/0/0/0   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


                                      Could not connect to any license server.


                                      The server is down or is not responsive.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/13 195:08    NEW_CONNECTION     


                                      Connected to license server: 2325@server.edu.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/13 195:08    RECONNECT                                                                                       7/38/78566/78566   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


      2019/08/13 195:09    INFO                                                                                            7/38/78566/78566   10748:ANS_INFO:Mike@Mike-HP:winx64                         10536:10.0.28.70   


                                      License server connection restored.


                                      Connected to server 2325@server.edu.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu


      2019/08/13 20:10:20    NEW_CONNECTION     


                                      Connected to license server: 2325@server.edu.


                                          ANSYSLI_SERVERS: 2325@server.edu


                                          FLEXlm Servers: 1055@server.edu

    • tsiriaks
      Ansys Employee

      This log seems to be old. Does this align with the time that the professor encountered the issue ?


      On the license server machine, open up the installed license file(s) , default under, C:Program FilesANSYS IncShared FilesLicensinglicense_files*.lic, then check the first line of each installed license file, you will see SERVER


      Use that exact with ping command. Try pinging it from the license server machine and client machine, do you get the same IP ? If not, you have to correct this. You can modify hosts file on client side and see if it can force to resolve to the IP that server sees itself. 


      Also, on the client side, check if it specifies the server with the exact same . If not, check if that resolves to the same IP.


      Thanks,


      Win

Viewing 4 reply threads
  • You must be logged in to reply to this topic.